Bug 145213 - Window list applet doesn't show all applications on current desktop
Window list applet doesn't show all applications on current desktop
Status: CLOSED DUPLICATE of bug 138874
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 09:00 EST by Brian G. Anderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2005-01-15 09:00:27 EST
Description of problem:
I run a dual head display which I configured after setting up the
system and logging on to my account.  The dual head is set up as a
spanning desktop, and I have windows spanning the two displays. I only
have the default top and bottom panels on the left screen and no
panels on the right which is how the system set it up.

If I have two open windows, one on the left screen and one on the
right, only the window on the same screen as the panel shows up in the
window list applet.  If I move the right window over then it appears
in the window list.  This is a change from fc2 where the single window
list would show all widows over all screens. 

After experimentation I realized that if I added another panel on the
right screen with its own window list applet then the window would
show up there.

This is a confusing change from FC2 to FC3 (I'm guessing arising from
the change from gnome 2.6 to 2.8) that appears to leave a user on a
spanning dual display with a broken window list application.  If there
is only one window list applet it should show all windows on all
screens.  The behavior of only showing the windows on the same screen
should only occur if there is a window list applet on the other screen.


Version-Release number of selected component (if applicable):
gnome-applets-2.8.0-5


How reproducible:
always


Steps to Reproduce:
1. setup a system and login as a user
2. configure dual head display as spanning desktops
3. put a window on the screen with no panel
  
Actual results:
window list applet only shows windows on that screen


Expected results:
window list applet should have shown all windows.


Additional info:
Comment 1 Brian G. Anderson 2005-01-15 09:04:47 EST
I should add that the reason that this is pretty important to me is
that I VNC into my machine regularly and VNC only shows the left
screen which happens to have all the panels.  When a new window is
created it sometimes appears on the screen VNC doesn't show.  With FC2
behavior at least I could move the new window by issuing a move action
throught he window list applet.  With this new behavior I can't get to
the window at all now.
Comment 2 Mark McLoughlin 2005-01-17 04:38:50 EST

*** This bug has been marked as a duplicate of 138874 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.