Bug 1452140 - [abrt] kdeconnectd: qt_message_fatal(): kdeconnectd killed by SIGABRT
Summary: [abrt] kdeconnectd: qt_message_fatal(): kdeconnectd killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1370222
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-connect
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:188bb610a49568c547f7d4d5b9b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-18 12:25 UTC by Samuel Lee
Modified: 2017-05-18 13:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-18 13:48:04 UTC


Attachments (Terms of Use)
File: backtrace (30.50 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: cgroup (242 bytes, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: core_backtrace (4.36 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: dso_list (12.34 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: environ (2.01 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: limits (1.29 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: maps (54.95 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: mountinfo (3.68 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: namespaces (102 bytes, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: open_fds (189 bytes, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: proc_pid_status (1.24 KB, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details
File: var_log_messages (440 bytes, text/plain)
2017-05-18 12:26 UTC, Samuel Lee
no flags Details

Description Samuel Lee 2017-05-18 12:25:58 UTC
Version-Release number of selected component:
kdeconnectd-1.0.3-1.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/kdeconnectd
crash_function: qt_message_fatal
executable:     /usr/libexec/kdeconnectd
global_pid:     14956
kernel:         4.10.13-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 qt_message_fatal at global/qlogging.cpp:1682
 #4 QXcbConnection::QXcbConnection(QXcbNativeInterface*, bool, unsigned int, char const*) at qxcbconnection.cpp:595
 #5 QXcbIntegration::QXcbIntegration(QStringList const&, int&, char**) at qxcbintegration.cpp:186
 #6 QXcbIntegrationPlugin::create(QString const&, QStringList const&, int&, char**) at qxcbmain.cpp:56
 #7 QPlatformIntegrationFactory::create(QString const&, QStringList const&, int&, char**, QString const&) at kernel/qplatformintegrationfactory.cpp:71
 #8 init_platform at kernel/qguiapplication.cpp:1094
 #9 QGuiApplicationPrivate::createPlatformIntegration() at kernel/qguiapplication.cpp:1257
 #10 QGuiApplicationPrivate::createEventDispatcher() at kernel/qguiapplication.cpp:1274
 #11 QCoreApplicationPrivate::init() at kernel/qcoreapplication.cpp:787
 #12 QGuiApplicationPrivate::init() at kernel/qguiapplication.cpp:1297

Comment 1 Samuel Lee 2017-05-18 12:26:08 UTC
Created attachment 1279974 [details]
File: backtrace

Comment 2 Samuel Lee 2017-05-18 12:26:09 UTC
Created attachment 1279975 [details]
File: cgroup

Comment 3 Samuel Lee 2017-05-18 12:26:11 UTC
Created attachment 1279976 [details]
File: core_backtrace

Comment 4 Samuel Lee 2017-05-18 12:26:14 UTC
Created attachment 1279977 [details]
File: dso_list

Comment 5 Samuel Lee 2017-05-18 12:26:15 UTC
Created attachment 1279978 [details]
File: environ

Comment 6 Samuel Lee 2017-05-18 12:26:17 UTC
Created attachment 1279979 [details]
File: limits

Comment 7 Samuel Lee 2017-05-18 12:26:19 UTC
Created attachment 1279980 [details]
File: maps

Comment 8 Samuel Lee 2017-05-18 12:26:21 UTC
Created attachment 1279981 [details]
File: mountinfo

Comment 9 Samuel Lee 2017-05-18 12:26:23 UTC
Created attachment 1279982 [details]
File: namespaces

Comment 10 Samuel Lee 2017-05-18 12:26:25 UTC
Created attachment 1279983 [details]
File: open_fds

Comment 11 Samuel Lee 2017-05-18 12:26:26 UTC
Created attachment 1279984 [details]
File: proc_pid_status

Comment 12 Samuel Lee 2017-05-18 12:26:28 UTC
Created attachment 1279985 [details]
File: var_log_messages

Comment 13 Rex Dieter 2017-05-18 13:48:04 UTC
from var_log_messages:

localhost.localdomain kdeconnectd[14956]: QXcbConnection: Could not connect to display :0

likely invalid xauth issue and dup of bug #1370222	(or something worse)

*** This bug has been marked as a duplicate of bug 1370222 ***


Note You need to log in before you can comment on or make changes to this bug.