Bug 1452227 - [RFE] Azure managed images not discovered
Summary: [RFE] Azure managed images not discovered
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.3
Assignee: Daniel Berger
QA Contact: Jeff Teehan
URL:
Whiteboard: provider:azure:images
Depends On: 1439815
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-18 15:47 UTC by Satoe Imaishi
Modified: 2020-09-10 10:35 UTC (History)
15 users (show)

Fixed In Version: 5.7.3.2
Doc Type: Enhancement
Doc Text:
Clone Of: 1439815
Environment:
Last Closed: 2017-06-28 15:03:41 UTC
Category: ---
Cloudforms Team: Azure
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:1601 0 normal SHIPPED_LIVE Important: CFME 5.7.3 security, bug fix and enhancement update 2017-06-28 18:51:52 UTC

Comment 2 Greg Blomquist 2017-05-23 20:38:16 UTC
https://github.com/ManageIQ/manageiq/pull/15164

Comment 3 Jeff Teehan 2017-06-13 16:14:19 UTC
I look at this.

Comment 5 Daniel Berger 2017-06-13 18:05:47 UTC
Jeff, only managed images were added, not managed disks.

Comment 6 Jeff Teehan 2017-06-13 19:20:45 UTC
Added test case and tried again with Image.

Created Managed image using https://docs.microsoft.com/en-us/azure/virtual-machines/windows/capture-image-resource

PS C:\Users\Administrator.CFME-QE-VMM-AD> Get-AzureRmImage  -ResourceGroupName Automation


ResourceGroupName    : Automation
SourceVirtualMachine : Microsoft.Azure.Management.Compute.Models.SubResource
StorageProfile       : Microsoft.Azure.Management.Compute.Models.ImageStorageProfile
ProvisioningState    : Succeeded
Id                   : /subscriptions/c9e72ccc-b20e-48bd-a0c8-879c6dbcbfbb/resourceGroups/Automation/providers/Microsoft.Compute/images/WS2016M
                       I1
Name                 : WS2016MI1
Type                 : Microsoft.Compute/images
Location             : eastus2
Tags                 : {}

Comment 7 Jeff Teehan 2017-06-14 20:03:41 UTC
Tested with additional PR first.  Should be in 5732.

Comment 8 Jeff Teehan 2017-06-14 20:04:38 UTC
Here's what I used:
https://github.com/ManageIQ/manageiq/pull/15369

Comment 9 Jeff Teehan 2017-06-26 17:01:10 UTC
Two managed images.
View this item	WS2016MI1	azure			64 bit				Region 623
	View this item	WS2016MI2a	azure			64 bit				Region 623

Moving to verified.

Comment 11 errata-xmlrpc 2017-06-28 15:03:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:1601

Comment 12 Jeff Teehan 2017-07-13 04:03:59 UTC
Josh, that customer ticket 01869501 is going to hit this:  https://bugzilla.redhat.com/show_bug.cgi?id=1470491

I should have caught that.  It worked in LifeCycle provision and the image showed up in Catalog, but I didn't push it through.

This bug is fixed.  You should probably move that ticket to the new bug.


Note You need to log in before you can comment on or make changes to this bug.