Bug 145223 - Mount point for USB disk corrupt
Mount point for USB disk corrupt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 11:31 EST by Peter Verthez
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 13:52:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from 'hald --daemon=no --verbose=yes' (7.94 KB, text/plain)
2005-01-15 11:32 EST, Peter Verthez
no flags Details

  None (edit)
Description Peter Verthez 2005-01-15 11:31:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Since installing this version (update of this week), the mount point 
for my USB disk is no longer /mount/usbdisk, but /mount/Ap.

The "Ap" seems to be a random string (some variable uninitialized?)
When I look with mtools, the FAT16 filesystem on the USB disk has
no volume label, so it cannot come from that.

When downgrading to hal-0.4.2-1, the problem disappears.

I'll mark this bug as Normal, but since it may involve an
uninitialized variable, this may have security consequences.


Version-Release number of selected component (if applicable):
hal-0.4.5-1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to hal-0.4.5-1
2. Insert USB stick
    

Actual Results:  USB stick shows up as /media/Ap ("Ap" also shown as
text on GNOME icon)

Expected Results:  USB stick should be mounted on /media/usbdisk
(because it doesn't have
a volume label).


Additional info:

See attached output from 'hald --daemon=no --verbose=yes'.
Comment 1 Peter Verthez 2005-01-15 11:32:42 EST
Created attachment 109820 [details]
Output from 'hald --daemon=no --verbose=yes'
Comment 2 Peter Verthez 2005-01-15 11:34:54 EST
Should read /media/usbdisk and /media/Ap, of course.
Comment 3 David Zeuthen 2005-01-20 13:52:37 EST
This should be fixed in hal-0.4.6 which will be in Rawhide and FC3
updates soon. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.