Bug 145237 - filename encoding accent display
filename encoding accent display
Status: CLOSED DUPLICATE of bug 145233
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 13:56 EST by wow101
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 03:38:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wow101 2005-01-15 13:56:00 EST
Description of problem:

Accents written in filenames on windows show a garbled display in FC3
and previous versions.  For instance "más" is displayed as "m??s" 
I've tested this in Nautilus and Konqueror.  Also accents written in
FC3 show a garbled display in windows.  I've tried other distros:
Kanotix can read windows accents properly and Windows can read Kanotix
accents properly.  In other words Kanotix works well for this.  Ubuntu
can read windows accents, but Windows can't read Ubuntu accents. 
Anyways I know it can be done.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. see description
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sitsofe Wheeler 2005-01-15 17:15:14 EST
You will have to clarify - when you say Windows do you mean a FAT32 Windows
partition?

I always thought filename conversion was dependent on the iocharset and codepage
the partition was mounted with (there is no well to tell what it should be just
by looking at the disk though). Which language (and if you know what charset)
are you trying to use? Does that match what is in /etc/fstab for that partition?
Comment 2 Alexander Larsson 2005-01-17 04:18:23 EST
Nautilus/Gnome expects local filenames to be in utf8 unless you set
G_BROKEN_FILENAMES (then they're expected to be in the current locales encoding).

You need to mount the fat partition with iocharset utf8. How did it get mounted?
Comment 3 wow101 2005-01-17 15:27:34 EST
problem solved.  See bug 145233.

thanks.
Comment 4 Alexander Larsson 2005-01-18 03:38:14 EST

*** This bug has been marked as a duplicate of 145233 ***

Note You need to log in before you can comment on or make changes to this bug.