Bug 1452401 - [3.4] ARP cache size not increased for atomic-openshift-node-host tuned profile
Summary: [3.4] ARP cache size not increased for atomic-openshift-node-host tuned profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 3.4.1
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.4.z
Assignee: Scott Dodson
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On: 1452235 1452402
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-18 21:15 UTC by Scott Dodson
Modified: 2017-06-15 18:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The ARP Cache size tuning parameters were not set when performing an install on bare metal hosts. The bare metal profiles have been updated to ensure that the arp cache is set correctly on bare metal hosts.
Clone Of: 1452235
Environment:
Last Closed: 2017-06-15 18:40:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1425 0 normal SHIPPED_LIVE OpenShift Container Platform 3.5, 3.4, 3.3, and 3.2 bug fix update 2017-06-15 22:35:53 UTC

Description Scott Dodson 2017-05-18 21:15:51 UTC
+++ This bug was initially created as a clone of Bug #1452235 +++

Description of problem:

tuned-profiles-atomic-openshift-node-3.5.*.rpm(s) contain an outdated atomic-openshift-node-host profile.

Version-Release number of selected component (if applicable):
tuned-profiles-atomic-openshift-node-3.5.5.17-1.git.0.28f23d1.el7.x86_64.rpm and lower.

$ oc version
oc v3.5.5.10
kubernetes v1.5.2+43a9be4
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://192.1.0.133:8443
openshift v3.5.5.10
kubernetes v1.5.2+43a9be4

How reproducible:
Always.

Steps to Reproduce:

$ rpm -qf /usr/lib/tuned/atomic-openshift-node-guest/tuned.conf
tuned-profiles-atomic-openshift-node-3.5.5.5-1.git.0.f2e87ab.el7.x86_64

$ grep gc_ /usr/lib/tuned/atomic-openshift-node-host/tuned.conf
$ grep gc_ /usr/lib/tuned/atomic-openshift-node-guest/tuned.conf
net.ipv4.neigh.default.gc_thresh1=8192
net.ipv4.neigh.default.gc_thresh2=32768
net.ipv4.neigh.default.gc_thresh3=65536

$ curl -Ls https://raw.githubusercontent.com/openshift/origin/master/contrib/tuned/origin-node-host/tuned.conf | grep gc_
net.ipv4.neigh.default.gc_thresh1=8192
net.ipv4.neigh.default.gc_thresh2=32768
net.ipv4.neigh.default.gc_thresh3=65536

Actual results:


Expected results:

$ grep gc_ /usr/lib/tuned/atomic-openshift-node-host/tuned.conf
net.ipv4.neigh.default.gc_thresh1=8192
net.ipv4.neigh.default.gc_thresh2=32768
net.ipv4.neigh.default.gc_thresh3=65536

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=1425388

Checked tuned-profiles-atomic-openshift-node-3.6.74-1.git.0.e6d1637.el7.x86_64.rpm and it is fixed there, so it only looks like 3.5.x is affected?

--- Additional comment from Scott Dodson on 2017-05-18 12:31:16 EDT ---

https://github.com/openshift/ose/pull/755

Comment 1 Scott Dodson 2017-05-18 21:24:19 UTC
https://github.com/openshift/ose/pull/756

Comment 3 Meng Bo 2017-06-02 06:29:11 UTC
Verified on ocp build v3.4.1.30

# grep gc_ /usr/lib/tuned/atomic-openshift-node-host/tuned.conf
net.ipv4.neigh.default.gc_thresh1=8192
net.ipv4.neigh.default.gc_thresh2=32768
net.ipv4.neigh.default.gc_thresh3=65536

#  sysctl -a | grep ipv4.neigh.default.gc_thresh
net.ipv4.neigh.default.gc_thresh1 = 8192
net.ipv4.neigh.default.gc_thresh2 = 32768
net.ipv4.neigh.default.gc_thresh3 = 65536

Comment 5 errata-xmlrpc 2017-06-15 18:40:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1425


Note You need to log in before you can comment on or make changes to this bug.