Bug 145246 - Postscript printing troubles
Postscript printing troubles
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 16:38 EST by Carlos Rodrigues
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 15:06:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
printconf-tui --Xexport (2.76 KB, text/xml)
2005-01-29 13:24 EST, Carlos Rodrigues
no flags Details
Output from printconf-tui --Xexport (3.22 KB, text/plain)
2005-03-15 01:09 EST, Bob Gustafson
no flags Details

  None (edit)
Description Carlos Rodrigues 2005-01-15 16:38:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
I'm having trouble printing postscript files. My home cups server
(RH9, with a raw queue, working flawlessly for months) rejects the job
with "print_job: No file!?!" upon which my FC3's CUPS stops the printer.

Sometimes, after printing some stuff in between (because strangely I
can print the test pages), it starts working again.

I've been inspecting the logs with "debug2" set, and nothing seems
wrong, except the above mentioned error.

This never happened before, and the only change I remember that could
be related to this, is the CUPS update from some says ago.

I'm having trouble reproducing, because I can't figure out what's the
problem...

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8.3

How reproducible:
Sometimes
Comment 1 Tim Waugh 2005-01-17 10:38:53 EST
Please attach the output of 'printconf-tui --Xexport' from the FC3 machine.
Comment 2 Carlos Rodrigues 2005-01-29 13:24:10 EST
Created attachment 110396 [details]
printconf-tui --Xexport

This is the output from "printconf-tui --Xexport" as requested. I already had
removed the printer and added it again, don't know if it matters.
Comment 3 Tim Waugh 2005-02-02 10:55:10 EST
Is sulaco.intranet.pt the RH9 machine?  If so, what version of CUPS is it
running?  How about if you upgrade it to 1.1.23 if that's not what it's running?
Comment 4 Carlos Rodrigues 2005-02-02 15:06:42 EST
It's "cups-1.1.17-13.3.0.6.legacy".

But I personally don't think that the problem is related to the server-side
cups, because it has been running fine for ages (and the print queue is plain
RAW), and at the same time I was having troubles printing from FC3, another
machine printed fine from Windows (XP, also using IPP directly).

I don't print often, but the problems seem to have went away. Maybe the printer
reconfiguration placed a new ppd in /etc/cups/ppd and that was the source of the
problem (old ppd + new cups). But don't trust me ;)

Anyway, this to say that I'm not sure that this bug is valid anymore. However,
the PPD being the problem or not, I guess a new CUPS install should also update
the PPDs in /etc/cups/ppd (the ones copied there by cups itself). But I guess
this could be considered an enhancement and not a bug.
Comment 5 Bob Gustafson 2005-03-15 01:09:38 EST
Created attachment 112006 [details]
Output from printconf-tui --Xexport

I know this bug is closed, but I am getting the same vague problems.

I have a true postscript printer (HP 2100M). I would like for cups to do as
little as possible to the files headed for the printer. I have copied in the
mfg ppd file and that seems to be listed on the Cups 'Printer Test Page' in the
box labeled Interpreter Information.

As the original bug submitter, I have been running this printer for years and
it has been working well, although there was always a certain amount of agony
involved in getting it to work when installing a new 'clean' version of Fedora.
I needed to reload Fedora over the weekend when I over ambitiously tried to go
from F3 core + update-released to Rawhide. Somehow lost all my soft links in
the /lib/modules directory (but this is another story).

I installed a clean FC3 and then installed the updates using the unmodified
up2date channels. This involved about 650+ MB of .hdr and .rpm downloads.

Then copied in the ppd, a bit of trial and error on the printer configuration
as I had done before and printed out a couple of Test pages. So far, things
working well.

Then am trying to print an OpenOffice text document. Strange symptoms (but ones
I have seen in the past under similar 'initial configuration' setting).

The printer light blinks as if it is receiving a file, then it stops blinking
and goes to normal green idle. BUT, NO PAPER COMES OUT.

Going into http://localhost:631/ and looking at jobs, all the non-printing jobs

show as 'completed' along with the Test jobs. As before, I stop and then
restart the printer - usually this would jog things into working, but not this
time.

The printer has a jet-direct interface and is on a network with Macs and a
solitary Windows XP machine. These other machines can print with no problem and
no wrassle with the config (although the Windows machine prints through some
'HP Mobile Printing' thingy - I need to click on Print and then a different
dialog Print again - a bit annoying).

I have rebooted several times - still same symptoms.

Printing is pretty basic to a home or small business machine. If I were a
paranoid fellow, this continuing printer configuration problem would get me
thinking.

The documentation available to a 'trial and error' fellow like myself is not
very goal oriented. On the localhost:631 page, clicking 'Help' and then opening
the 'User Manual', I see things that appear to be definitions and not 'how to'
oriented paragraphs. I wonder where the command 'printconf-tui --Xexport' is
found?

So, enough of my ranting and raving. Basically I need some help to get the
printed paper coming out of my printer. I can post whatever is needed.
Comment 6 Bob Gustafson 2005-03-15 01:30:26 EST
OK, fixed my problem

[root@hoho2 cups]# lpoptions -o raw
[root@hoho2 cups]#

How did I find this? Just read the whole HELP, User Manual, from
beginning to end.

Why does it work? Beats me.

There still are issues out there for the person trying to figure out
how to get a printer working under CUPS.
Comment 7 Bob Gustafson 2005-04-13 11:56:18 EDT
Note that the command 'lpoptions -o raw' apparently does not survive a reboot.
It needs to be done again after reboot.

Note You need to log in before you can comment on or make changes to this bug.