Bug 145253 - Patch to fix RSS generation for Live Bookmarks
Summary: Patch to fix RSS generation for Live Bookmarks
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-15 23:39 UTC by Ignacio Vazquez-Abrams
Modified: 2014-01-21 22:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 19:22:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to yum for RSS generation (2.58 KB, patch)
2005-01-15 23:40 UTC, Ignacio Vazquez-Abrams
no flags Details | Diff
Spruced-up RSS generation script (7.96 KB, text/plain)
2005-02-23 02:25 UTC, Ignacio Vazquez-Abrams
no flags Details
Latest revision of repo-rss.py (8.20 KB, text/plain)
2005-03-10 18:51 UTC, Ignacio Vazquez-Abrams
no flags Details

Description Ignacio Vazquez-Abrams 2005-01-15 23:39:31 UTC
The included patch fixes the RSS generation for yum making it
compatible with Firefox's Live Bookmarks, as well as improving the
visual appearance in Sage.

Comment 1 Ignacio Vazquez-Abrams 2005-01-15 23:40:35 UTC
Created attachment 109831 [details]
Patch to yum for RSS generation

Comment 2 Seth Vidal 2005-01-16 09:58:37 UTC
So I like the top part of your patch. Sorting by day to print the most
recent ones in the list first. That makes sense. I'm a bit confused by
the second part. It seems a bit odd to remove the xhtml tag to allow
it to be prettier in sage. Wouldn't it make more sense to fix Sage to
work better with xhtml inside rss feeds?

And what's wrong with the package being keyed on the pkgid?


Comment 3 Seth Vidal 2005-01-16 10:02:25 UTC
Ah ha - I just pulled it up in sage - I can see why that might be
annoying. Are you sure it's not just a problem in sage? Liferea
appears to render it correctly as does the feedparser used in the
planetplanet code.


Comment 4 Ignacio Vazquez-Abrams 2005-01-16 10:06:29 UTC
The main problem isn't Sage, it's Live Bookmarks. It likes neither the
body nor guid tags.

Comment 5 Seth Vidal 2005-01-16 10:09:46 UTC
It seems to not have a problem with the live bookmarks and guid tags from:
http://fedoraproject.org/people/rss20.xml



Comment 6 Ignacio Vazquez-Abrams 2005-01-16 10:13:37 UTC
I don't see any body tags in that feed. And I didn't completely
diagnose what the issue was with the guid tag.

Comment 7 Ignacio Vazquez-Abrams 2005-01-16 12:09:35 UTC
Huh. The guid needs a protocol in front of it. "sha1:" anyone?

Comment 8 Ignacio Vazquez-Abrams 2005-01-16 12:55:24 UTC
And while we're at it, it would be handy to be able to specify the
channel's title, link, and description on the command-line, as well as
override the URL used in the item link and be able to specify a
suffix, e.g., ".html".

Comment 9 Seth Vidal 2005-02-23 01:43:07 UTC
How about this.
I think I'm going to pull the generate-rss support from yum.

I wrote this last night:
http://linux.duke.edu/yum/download/misc/repo-rss.py

Would you care to spruce that up nicely?

Comment 10 Ignacio Vazquez-Abrams 2005-02-23 02:25:20 UTC
Created attachment 111320 [details]
Spruced-up RSS generation script

Mmm... spruce...

Looks like there's a small bug in the OptionParser bit whereby it prints
"%default" instead of the default. Maybe it's because I'm on 2.3.4 still.

But the rest looks good and works great.

Comment 11 Ignacio Vazquez-Abrams 2005-02-23 03:52:31 UTC
Oh, and the -r option appears to be broken. I don't think this is the scripts
fault though. Maybe it's yum's. I'm running 2.1.13.

Comment 12 Ignacio Vazquez-Abrams 2005-03-10 18:51:08 UTC
Created attachment 111865 [details]
Latest revision of repo-rss.py

Just thought I'd add the latest revision I made. Now adds the option to specify
a base URL for e.g. if you're generating the RSS against files on a drive but
need the links to point to files on the web.

Comment 13 Jeremy Katz 2005-09-21 19:22:58 UTC
The rss stuff is no longer in yum itself.  If there are problems with the code
in yum-utils, please file a report about that.


Note You need to log in before you can comment on or make changes to this bug.