Bug 1452597 (CVE-2017-9060) - CVE-2017-9060 Qemu: virtio-gpu: host memory leakage in Virtio GPU device
Summary: CVE-2017-9060 Qemu: virtio-gpu: host memory leakage in Virtio GPU device
Status: CLOSED NOTABUG
Alias: CVE-2017-9060
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20170122,reported=2...
Keywords: Security
Depends On: 1452598
Blocks: 1377134
TreeView+ depends on / blocked
 
Reported: 2017-05-19 10:02 UTC by Prasad J Pandit
Modified: 2019-06-08 22:01 UTC (History)
38 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-06-08 03:12:56 UTC


Attachments (Terms of Use)

Description Prasad J Pandit 2017-05-19 10:02:55 UTC
Quick Emulator(Qemu) built with the Virtio GPU Device emulator support is
vulnerable to a memory leakage issue. It could occur while processing
'VIRTIO_GPU_CMD_SET_SCANOUT:' command.

A guest user/process could use this flaw to leak host memory resulting in Dos.

Upstream patch:
---------------
  -> http://git.qemu.org/?p=qemu.git;a=commitdiff;h=dd248ed7e204ee8a1873914e02b8b526e8f1b80d

Reference:
----------
  -> http://www.openwall.com/lists/oss-security/2017/05/19/1

Comment 1 Prasad J Pandit 2017-05-19 10:03:37 UTC
Acknowledgments:

Name: Li Qiang (Qihoo 360 Gear Team)

Comment 2 Prasad J Pandit 2017-05-19 10:06:04 UTC
Created qemu tracking bugs for this issue:

Affects: fedora-all [bug 1452598]

Comment 3 Fedora Update System 2017-07-25 21:26:26 UTC
qemu-2.7.1-7.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.