Bug 1452600 - [abrt] dnfdragora: __call__(): __init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object
Summary: [abrt] dnfdragora: __call__(): __init__.py:187:__call__:RecursionError: maxim...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:262ebebddb185f587828b18971b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-19 10:07 UTC by Mike Simms
Modified: 2018-01-01 22:20 UTC (History)
7 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:37:27 UTC


Attachments (Terms of Use)
File: backtrace (691 bytes, text/plain)
2017-05-19 10:07 UTC, Mike Simms
no flags Details
File: cgroup (289 bytes, text/plain)
2017-05-19 10:07 UTC, Mike Simms
no flags Details
File: cpuinfo (1019 bytes, text/plain)
2017-05-19 10:07 UTC, Mike Simms
no flags Details
File: environ (1.38 KB, text/plain)
2017-05-19 10:07 UTC, Mike Simms
no flags Details
File: mountinfo (3.37 KB, text/plain)
2017-05-19 10:07 UTC, Mike Simms
no flags Details
File: namespaces (102 bytes, text/plain)
2017-05-19 10:07 UTC, Mike Simms
no flags Details
File: open_fds (1.04 KB, text/plain)
2017-05-19 10:07 UTC, Mike Simms
no flags Details

Description Mike Simms 2017-05-19 10:07:38 UTC
Description of problem:
started a dnfdragora transaction to install f25-backgrounds-mate package in F26. it crashed while doing so but dnf backend completed the task anyway

Version-Release number of selected component:
dnfdragora-1.0.1-5.git20170505.2a3b056.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora
crash_function: __call__
exception_type: RecursionError
executable:     /usr/bin/dnfdragora
kernel:         4.11.1-300.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:187:__call__:RecursionError: maximum recursion depth exceeded while calling a Python object

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 187, in __call__
    return getattr(self.proxy, self.method)(*args)
RecursionError: maximum recursion depth exceeded while calling a Python object

Local variables in innermost frame:
args: (<Gio.DBusProxy object at 0x7f3d92a03dc8 (GDBusProxy at 0x55baf17169d0)>, ':1.53', 'DownloadProgress', GLib.Variant('(sddi)', ('f25-backgrounds-base-25.1.1-3.fc26.noarch.rpm', 0.77001609730193643, 0.77009645177893038, 1)))
self: <dnfdaemon.client.WeakMethod object at 0x7f3d929e99b0>

Comment 1 Mike Simms 2017-05-19 10:07:45 UTC
Created attachment 1280358 [details]
File: backtrace

Comment 2 Mike Simms 2017-05-19 10:07:47 UTC
Created attachment 1280359 [details]
File: cgroup

Comment 3 Mike Simms 2017-05-19 10:07:49 UTC
Created attachment 1280360 [details]
File: cpuinfo

Comment 4 Mike Simms 2017-05-19 10:07:51 UTC
Created attachment 1280361 [details]
File: environ

Comment 5 Mike Simms 2017-05-19 10:07:52 UTC
Created attachment 1280362 [details]
File: mountinfo

Comment 6 Mike Simms 2017-05-19 10:07:54 UTC
Created attachment 1280363 [details]
File: namespaces

Comment 7 Mike Simms 2017-05-19 10:07:56 UTC
Created attachment 1280364 [details]
File: open_fds

Comment 8 Rob Mamede 2017-07-27 02:09:46 UTC
*** Bug 1475620 has been marked as a duplicate of this bug. ***

Comment 9 Bill Pechter 2017-10-10 02:16:32 UTC
*** Bug 1500131 has been marked as a duplicate of this bug. ***

Comment 10 David Poulsen 2017-10-14 17:23:30 UTC
*** Bug 1502157 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2017-12-30 00:36:31 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 12 Fedora Update System 2017-12-30 00:38:25 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 13 Fedora Update System 2017-12-30 20:03:08 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 14 Fedora Update System 2017-12-30 20:48:51 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 15 Fedora Update System 2017-12-31 21:37:27 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2018-01-01 22:20:37 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.