Bug 1452605 - disable pulseaudio and alsa support
Summary: disable pulseaudio and alsa support
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Chao Yang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1382275
TreeView+ depends on / blocked
 
Reported: 2017-05-19 10:23 UTC by Gerd Hoffmann
Modified: 2017-08-02 04:41 UTC (History)
11 users (show)

Fixed In Version: qemu-kvm-rhev-2.9.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 04:41:00 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:2392 normal SHIPPED_LIVE Important: qemu-kvm-rhev security, bug fix, and enhancement update 2017-08-01 20:04:36 UTC

Description Gerd Hoffmann 2017-05-19 10:23:20 UTC
Description of problem:
qemu has pulseaudio support enabled.
It is not used though, we don't have any local display UIs enabled (gtk/sdl).
libvirt doesn't support audio via pulse too.
So we should be able to turn it off without any regressions.
This will significantly reduce the footprint of both shared libraries loaded and package dependencies as pulse drags in a bunch of X11 libs.

Comment 6 Miroslav Rezanina 2017-05-23 08:16:36 UTC
Fix included in qemu-kvm-rhev-2.9.0-6.el7

Comment 8 Guo, Zhiyi 2017-06-12 09:40:17 UTC
For this bug, I think rpmreaper really does its job to verify the package dependencies of qemu-kvm-rhev.
This is the package dependencies of qemu-kvm-rhev-2.9.0-5.el7.x86_64.rpm:
       11.2M qemu-kvm-rhev             2.9.0-5.el7.x86_64                                                                                                         
        1.4M ├─> alsa-lib                  1.1.3-3.el7.x86_64                                                                                                     
  o     3.5M ├─> bash                      4.2.46-28.el7.x86_64                                                                                                   
        388K ├─> cyrus-sasl-lib            2.1.26-21.el7.x86_64                                                                                                   
  o    11.1M ├─> glib2                     2.50.3-3.el7.x86_64                                                                                                    
  o    13.5M ├─> glibc                     2.17-194.el7.x86_64                                                                                                    
        170K ├─> glusterfs-api             3.8.4-18.el7.x86_64                                                                                                    
        1.2M ├─> glusterfs-libs            3.8.4-18.el7.x86_64                                                                                                    
        2.0M ├─> gnutls                    3.3.26-8.el7.x86_64                                                                                                    
        1.4M ├─> gperftools-libs           2.4-8.el7.x86_64                                                                                                       
        1.5M ├─> ipxe-roms-qemu            20170123-1.git4e85b27.el7.noarch                                                                                       
         37K ├─> libacl                    2.2.51-12.el7.x86_64                                                                                                   
         39K ├─> libaio                    0.3.109-13.el7.x86_64                                                                                                  
         49K ├─> libcacard                 2.5.2-2.el7.x86_64                                                                                                     
  o     425K ├─> libcurl                   7.29.0-42.el7.x86_64                                                                                                   
        176K ├─> libgcc                    4.8.5-16.el7.x86_64                                                                                                    
        523K ├─> libibverbs                13-7.el7.x86_64                                                                                                        
        157K ├─> libiscsi                  1.9.0-7.el7.x86_64                                                                                                     
        602K ├─> libpng                    1.5.13-7.el7_2.x86_64                                                                                                  
        5.5M ├─> librados2                 10.2.5-3.el7.x86_64                                                                                                    
        7.4M ├─> librbd1                   10.2.5-3.el7.x86_64                                                                                                    
        122K ├─> librdmacm                 13-7.el7.x86_64                                                                                                        
        297K ├─> libseccomp                2.3.1-3.el7.x86_64                                                                                                     
        334K ├─> libssh2                   1.4.3-10.el7_2.1.x86_64                                                                                                
  o     1.0M ├─> libstdc++                 4.8.5-16.el7.x86_64                                                                                                    
        135K ├─> libusbx                   1.0.20-1.el7.x86_64                                                                                                    
         20K ├─> libuuid                   2.23.2-43.el7.x86_64                                                                                                   
        162K ├─> lzo                       2.06-8.el7.x86_64                                                                                                      
        748K ├─> nettle                    2.7.1-8.el7.x86_64                                                                                                     
         50K ├─> numactl-libs              2.0.9-6.el7_2.x86_64                                                                                                   
  o     3.1M ├─> openssl-libs              1.0.2k-8.el7.x86_64                                                                                                    
        683K ├─> pixman                    0.34.0-1.el7.x86_64                                                                                                    
        3.2M ├─> pulseaudio-libs           10.0-3.el7.x86_64                                                                                                      
        6.4M ├─> qemu-img-rhev             2.9.0-5.el7.x86_64                                                                                                     
        2.7M ├─> qemu-kvm-common-rhev      2.9.0-5.el7.x86_64                                                                                                     
        384K ├─> seabios-bin               1.10.2-3.el7.noarch                                                                                                    
        223K ├─> seavgabios-bin            1.10.2-3.el7.noarch                                                                                                    
          4K ├─> sgabios-bin               0.20110622svn-4.el7.noarch                                                                                             
        117K ├─> snappy                    1.1.0-3.el7.x86_64                                                                                                     
        1.2M ├─> spice-server              0.12.8-2.el7.x86_64                                                                                                    
        106K ├─> usbredir                  0.7.1-2.el7.x86_64                                                                                                     
        182K └─> zlib                      1.2.7-17.el7.x86_64

This is the package dependencies of qemu-kvm-rhev-2.9.0-9.el7.x86_64.rpm:
       11.2M qemu-kvm-rhev             2.9.0-9.el7.x86_64                                                                                                         
  o     3.5M ├─> bash                      4.2.46-28.el7.x86_64                                                                                                   
        388K ├─> cyrus-sasl-lib            2.1.26-21.el7.x86_64                                                                                                   
  o    11.1M ├─> glib2                     2.50.3-3.el7.x86_64                                                                                                    
  o    13.5M ├─> glibc                     2.17-194.el7.x86_64                                                                                                    
        170K ├─> glusterfs-api             3.8.4-18.el7.x86_64                                                                                                    
        1.2M ├─> glusterfs-libs            3.8.4-18.el7.x86_64                                                                                                    
        2.0M ├─> gnutls                    3.3.26-8.el7.x86_64                                                                                                    
        1.4M ├─> gperftools-libs           2.4-8.el7.x86_64                                                                                                       
        1.5M ├─> ipxe-roms-qemu            20170123-1.git4e85b27.el7.noarch                                                                                       
         37K ├─> libacl                    2.2.51-12.el7.x86_64                                                                                                   
         39K ├─> libaio                    0.3.109-13.el7.x86_64                                                                                                  
         49K ├─> libcacard                 2.5.2-2.el7.x86_64                                                                                                     
  o     425K ├─> libcurl                   7.29.0-42.el7.x86_64                                                                                                   
        176K ├─> libgcc                    4.8.5-16.el7.x86_64                                                                                                    
        523K ├─> libibverbs                13-7.el7.x86_64                                                                                                        
        157K ├─> libiscsi                  1.9.0-7.el7.x86_64                                                                                                     
        602K ├─> libpng                    1.5.13-7.el7_2.x86_64                                                                                                  
        5.5M ├─> librados2                 10.2.5-3.el7.x86_64                                                                                                    
        7.4M ├─> librbd1                   10.2.5-3.el7.x86_64                                                                                                    
        122K ├─> librdmacm                 13-7.el7.x86_64                                                                                                        
        297K ├─> libseccomp                2.3.1-3.el7.x86_64                                                                                                     
        334K ├─> libssh2                   1.4.3-10.el7_2.1.x86_64                                                                                                
  o     1.0M ├─> libstdc++                 4.8.5-16.el7.x86_64                                                                                                    
        135K ├─> libusbx                   1.0.20-1.el7.x86_64                                                                                                    
         20K ├─> libuuid                   2.23.2-43.el7.x86_64                                                                                                   
        162K ├─> lzo                       2.06-8.el7.x86_64                                                                                                      
        748K ├─> nettle                    2.7.1-8.el7.x86_64                                                                                                     
         50K ├─> numactl-libs              2.0.9-6.el7_2.x86_64                                                                                                   
  o     3.1M ├─> openssl-libs              1.0.2k-8.el7.x86_64                                                                                                    
        683K ├─> pixman                    0.34.0-1.el7.x86_64                                                                                                    
        6.4M ├─> qemu-img-rhev             2.9.0-9.el7.x86_64                                                                                                     
        2.8M ├─> qemu-kvm-common-rhev      2.9.0-9.el7.x86_64                                                                                                     
        384K ├─> seabios-bin               1.10.2-3.el7.noarch                                                                                                    
        223K ├─> seavgabios-bin            1.10.2-3.el7.noarch                                                                                                    
          4K ├─> sgabios-bin               0.20110622svn-4.el7.noarch                                                                                             
        117K ├─> snappy                    1.1.0-3.el7.x86_64                                                                                                     
        1.2M ├─> spice-server              0.12.8-2.el7.x86_64                                                                                                    
        106K ├─> usbredir                  0.7.1-2.el7.x86_64                                                                                                     
        182K └─> zlib                      1.2.7-17.el7.x86_64                                                                                                    

Package dependencies alsa-lib and pulseaudio-libs cannot be found within qemu-kvm-rhev-2.9.0-9.el7.x86_64.rpm.

Hi Gerd,
   Please refer to the test result, is it ok to verify this bug? Many thanks!

BR/
Guo, Zhiyi

Comment 9 Gerd Hoffmann 2017-06-12 09:43:26 UTC
  Hi,

> Package dependencies alsa-lib and pulseaudio-libs cannot be found within
> qemu-kvm-rhev-2.9.0-9.el7.x86_64.rpm.

Yes, looks good.

Comment 10 Guo, Zhiyi 2017-06-12 09:52:32 UTC
Verified per comment 8-9

Comment 12 errata-xmlrpc 2017-08-02 04:41:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:2392


Note You need to log in before you can comment on or make changes to this bug.