Bug 145269 - Upgrade to 2.6.10-1.737_FC3 : No sensors found !
Summary: Upgrade to 2.6.10-1.737_FC3 : No sensors found !
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-16 11:49 UTC by George König
Modified: 2015-01-04 22:15 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-07-07 20:53:07 UTC


Attachments (Terms of Use)

Description George König 2005-01-16 11:49:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Until kernel 2.6.9-1.724_FC3 I was able to monitoring CPU & sys temps
using lm_sensors (MB Abit KT7-RAID) loading i2c-isa and via686a
modules. Then the upgrade to kernel 2.6.10-1.737_FC3 and now
when start the lm_sensors service I receive a "No sensors found!",
same with the more recent kernel 2.6.10-1.741_FC3. If booting under
the old 2.6.9 kernel the sensors come back.

lm_sensors version is 2.8.7-2 

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel 2.6.10-1.737_FC3 or 2.6.10-1.741_FC3
2. start lm_sensors service

    

Actual Results:  No sensors found !
[FAILURE]

Expected Results:  If kernel is 2.6.9-1.724_FC3 all works, the temp
sensors are readable

Additional info:

Hardware: Abit KT7-RAID w/ VIA VT82C686A

lm_sensors is loading 
MODULE_0: i2c_isa
MODULE_1: via686a

Comment 1 Ian Pilcher 2005-01-16 18:34:51 UTC
Same thing here.  Abit VP6 with VIA 686A.

Comment 2 Ian Pilcher 2005-01-16 23:58:56 UTC
More info.  It is possible to get things working by rmmod'ing all of
the lm_sensors-related modules and then starting lm_sensors.

This seems to be related to the fact that *something* is causing the
i2c_core and i2c_viapro modules to be loaded before the lm_sensors
script is run.  (If I disable lm_sensors and reboot my system, these
two modules are loaded anyway.)

Comment 3 Ondrej Svejda 2005-01-17 12:42:48 UTC
rmmod'ing doesn't work for me. And I don't get "No sensors found"
either. Output from sensors is only

it8712-isa-0290
Adapter: ISA adapter

My configuration is ASUS A7V600, lm_sensors modules it87 and i2c-isa.
BTW i2c_core is also used by bttv.

Comment 4 Wojciech Kazubski 2005-01-23 12:27:57 UTC
Have the same problem on Soltek 75KAV.
sensors on kernel 2.6.9-1.724 displated info on via686a sensors
(temperature, fan speed, etc) but no SDRAM memory info. After upgrade
to kernel 2.6.10-1.741 via sensors are missing but SDRAM memory info
is displayed. 
Both kernels show presence of Bt878 chip on TV card.

Driver load order had changed?

Comment 5 George König 2005-02-07 13:05:41 UTC
I've verified vanilla 2.6.10 kernel has the same problem.

Comment 6 Ian Pilcher 2005-02-07 21:35:23 UTC
I suggest opening a bug at http://bugzilla.kernel.org.

Comment 7 George König 2005-02-08 10:49:38 UTC
Opened. Bug # 4181

Comment 8 George König 2005-02-08 12:26:16 UTC
Jean Delvare (khali@linux-fr.org) said:

>I suspect that i2c-viapro gets in the way, since it is auto-loadable
>by hotplug since 2.6.10. Unload both via686a and i2c-viapro, then
>reload via686a, and sensors should be back.
>
>You can add i2c-viapro to /etc/hotplug/blacklist so that i2c-viapro
>won't get loaded at all. That should solve your problem.
>
>In 2.6.11, the conflict between i2c-viapro and via686a has been fixed
>so the blacklisting won't even be necessary anymore.


I just added i2c-viapro to the blacklist and now the sensors are back
again under 2.6.10 .
similar problems on ASUS and SOLTEK boards not powered by via chipsets
but equally accessing its sensors thru the isa bus have to blacklist
the corresponding conflict module until 2.6.11 fix that.

Comment 9 Ondrej Svejda 2005-02-19 18:44:35 UTC
Following fix from Bug # 145350 works for me:

modprobe it87 force_it87=9191,0x290

Comment 10 Ian Pilcher 2005-06-29 18:42:01 UTC
Shouldn't this bug be closed?


Note You need to log in before you can comment on or make changes to this bug.