Bug 1452737 - GUI: New "Bypass the HTTP proxy for specific hosts/domains" option in proxy configuration window is not saving the value for no_proxy parameter in rhsm.conf
Summary: GUI: New "Bypass the HTTP proxy for specific hosts/domains" option in proxy c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-19 14:18 UTC by Rehana
Modified: 2017-08-01 19:24 UTC (History)
5 users (show)

Fixed In Version: subscription-manager-1.19.15-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:24:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
proxy (302.52 KB, image/png)
2017-05-19 14:21 UTC, Rehana
no flags Details
noproxy_setting_from_GUI (868.83 KB, image/png)
2017-05-25 09:14 UTC, Rehana
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1633 None None None 2017-05-23 09:46:38 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Rehana 2017-05-19 14:18:59 UTC
Description of problem:
Observed that the value given for "Bypass the HTTP proxy for specific hosts/domains" option in the "proxy configuration" window from GUI is not saving the value

Version-Release number of selected component (if applicable):
]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.14-1.el7
python-rhsm: 1.19.6-1.el7


How reproducible:
always

Steps to Reproduce:
1.Launch subscription-manager-gui 
2.try to set proxy from "configure proxy" dialog
3.Enter the proxy server details and enter the hostname to bypass the proxy
4. Save 

Actual results:
no value updated for" no_proxy "in rhsm.conf, though the proxy details are saved in the rhsm.cong

Expected results:
it should update the proxy  and no proxy details

Additional info:

Comment 1 Rehana 2017-05-19 14:20:27 UTC
attaching screen shot from GUI (PFA.proxy) and List the proxy config in cli

[root@sentinel ~]# subscription-manager config --list | grep proxy
   no_proxy = []
   proxy_hostname = auto-services.usersys.redhat.com
   proxy_password = []
   proxy_port = 3129
   proxy_user = []
[root@sentinel ~]#

Comment 2 Rehana 2017-05-19 14:21:18 UTC
Created attachment 1280434 [details]
proxy

Comment 4 Rehana 2017-05-25 09:14:14 UTC
Verifying on :
===========

# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.15-1.el7
python-rhsm: 1.19.6-1.el7

# rpm -qa subscription-manager --changelog | grep 1452737
- 1452737: Enable saving no_proxy settings from GUI (jhnidek@redhat.com)

before setting proxy details from GUI :
=========================================

[root@ibm-x3250m3-01 ~]# subscription-manager config --list | grep proxy
   no_proxy = []
   proxy_hostname = []
   proxy_password = []
   proxy_port = []
   proxy_user = []


set the proxy details from GUI (PFA :noproxy_setting_from_GUI.png)

After setting the details from gui :
=====================================

[root@ibm-x3250m3-01 ~]# subscription-manager config --list | grep proxy
   no_proxy = redhat.com,foo.com
   proxy_hostname = auto-services.usersys.redhat.com
   proxy_password = []
   proxy_port = 3129
   proxy_user = []

Marking the bug as verified!!

Comment 5 Rehana 2017-05-25 09:14:51 UTC
Created attachment 1282169 [details]
noproxy_setting_from_GUI

Comment 6 errata-xmlrpc 2017-08-01 19:24:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.