Bug 1452762 - [RFE] RGW implement ansible installation and setup of RGW NFS
Summary: [RFE] RGW implement ansible installation and setup of RGW NFS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: All
OS: All
high
high
Target Milestone: rc
: 3.0
Assignee: Ali Maredia
QA Contact: vidushi
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-05-19 14:53 UTC by Matt Benjamin (redhat)
Modified: 2017-12-05 23:33 UTC (History)
13 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.0-0.1.rc8.1.el7cp Ubuntu: ceph-ansible_3.0.0~rc8-2redhat1
Doc Type: Enhancement
Doc Text:
.Installing NFS Ganesha by using Ansible is supported You can now install the NFS Ganesha interface by using the `ceph-ansible` playbook. For additional details, see the `all.yml` and `nfss.yml` file in the `/usr/share/ceph-ansible/` directory on the Ansible administration node.
Clone Of:
Environment:
Last Closed: 2017-12-05 23:33:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 1780 None None None 2017-08-21 18:51:32 UTC
Github ceph ceph-ansible pull 1880 None None None 2017-09-11 13:07:36 UTC
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Description Matt Benjamin (redhat) 2017-05-19 14:53:09 UTC
Description of problem:
Current Ansible installer can install radosgw instances, but not nfs-ganesha/RGW instances.  Add support for installation of NFS gateways.

Version-Release number of selected component (if applicable):
2.x

How reproducible:
100%

Comment 2 Ali Maredia 2017-08-21 18:05:10 UTC
Here is a PR for the BZ:

https://github.com/ceph/ceph-ansible/pull/1780

I'm hoping it will be merged within the next day or two.

Comment 3 Ali Maredia 2017-09-11 13:07:36 UTC
After further testing of ansible, this PR is also necessary. It is ready to merge and is passing all the automated tests.

Comment 6 Ali Maredia 2017-09-14 16:34:55 UTC
PR 1880 has been merged. Moving the BZ onto POST.

Comment 17 Daniel Gryniewicz 2017-10-31 13:58:32 UTC
I think, long term, we should stop the kNFS service if we're starting Ganesha.

Comment 21 vidushi 2017-11-02 13:15:39 UTC
Thanks so much Ali.

Comment 23 Ali Maredia 2017-11-02 22:19:30 UTC
Bara, could you add something in the release notes about making sure that the knfs service should not be running on the node the nfs-ganesha is going to be installed and run on.

Comment 27 errata-xmlrpc 2017-12-05 23:33:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.