Bug 1452876 - Invalid symlink in /usr/bin/cinnamon-settings-daemon
Summary: Invalid symlink in /usr/bin/cinnamon-settings-daemon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon-settings-daemon
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1452877 1452909 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-19 20:10 UTC by Lars Kiesow
Modified: 2017-06-09 19:10 UTC (History)
4 users (show)

Fixed In Version: cinnamon-settings-daemon-3.4.1-1.fc25 cinnamon-settings-daemon-3.4.1-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-09 11:29:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Lars Kiesow 2017-05-19 20:10:35 UTC
Description of problem:

After upgrading the cinnamon packages, I noticed that the screen brightness control buttons do not work anymore. Looking at journalctl, I got:

May 19 22:06:42 lars csd-media-keys[1610]: Failed to get old screen percentage: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.cinnamon.SettingsDaemon was not provided by any .service files

After which I noticed that the cinnamon-settings-daemon did not run at all, which lead me to notice that there is an invalid symlink in /usr/bin/cinnamon-settings-daemon which might be the cause:

% ll /usr/bin/cinnamon-settings-daemon
lrwxrwxrwx. 1 root root 37 May  8 21:45 /usr/bin/cinnamon-settings-daemon -> /usr/libexec/cinnamon-settings-daemon
% ll /usr/libexec/cinnamon-settings-daemon
ls: cannot access '/usr/libexec/cinnamon-settings-daemon': No such file or directory


Version-Release number of selected component (if applicable):
3.4.0-1.fc25

Comment 1 leigh scott 2017-05-19 22:27:44 UTC
*** Bug 1452877 has been marked as a duplicate of this bug. ***

Comment 2 leigh scott 2017-05-19 22:36:26 UTC
(In reply to Lars Kiesow from comment #0)
> Description of problem:
> 
> After upgrading the cinnamon packages, I noticed that the screen brightness
> control buttons do not work anymore. Looking at journalctl, I got:
> 
> May 19 22:06:42 lars csd-media-keys[1610]: Failed to get old screen
> percentage: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
> org.cinnamon.SettingsDaemon was not provided by any .service files
> 

Fixed by this update currently in testing repo

https://bodhi.fedoraproject.org/updates/FEDORA-2017-9788d934f2




> After which I noticed that the cinnamon-settings-daemon did not run at all,
> which lead me to notice that there is an invalid symlink in
> /usr/bin/cinnamon-settings-daemon which might be the cause:
> 
> % ll /usr/bin/cinnamon-settings-daemon
> lrwxrwxrwx. 1 root root 37 May  8 21:45 /usr/bin/cinnamon-settings-daemon ->
> /usr/libexec/cinnamon-settings-daemon
> % ll /usr/libexec/cinnamon-settings-daemon
> ls: cannot access '/usr/libexec/cinnamon-settings-daemon': No such file or
> directory
> 

This was a harmless leftover, fixed in git

http://pkgs.fedoraproject.org/cgit/rpms/cinnamon-settings-daemon.git/commit/?id=cf444e07684a6cb257d1ad218a5cf6b0e973deed

Comment 3 leigh scott 2017-05-20 06:46:05 UTC
*** Bug 1452909 has been marked as a duplicate of this bug. ***

Comment 4 Lars Kiesow 2017-05-20 07:40:59 UTC
Thanks for fixing the issue! …and sorry for double posting.

Comment 5 Fedora Update System 2017-05-23 19:56:22 UTC
nemo-3.4.2-1.fc25 cinnamon-3.4.1-1.fc25 cinnamon-desktop-3.4.1-1.fc25 cjs-3.4.1-1.fc25 cinnamon-translations-3.4.2-1.fc25 cinnamon-settings-daemon-3.4.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ae435e0c0

Comment 6 Fedora Update System 2017-05-23 19:56:51 UTC
nemo-3.4.2-1.fc26 cinnamon-3.4.1-1.fc26 cinnamon-desktop-3.4.1-1.fc26 cjs-3.4.1-1.fc26 cinnamon-translations-3.4.2-1.fc26 cinnamon-settings-daemon-3.4.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c08a63574

Comment 7 Fedora Update System 2017-05-25 19:19:47 UTC
cinnamon-3.4.1-1.fc26, cinnamon-desktop-3.4.1-1.fc26, cinnamon-settings-daemon-3.4.1-1.fc26, cinnamon-translations-3.4.2-1.fc26, cjs-3.4.1-1.fc26, nemo-3.4.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c08a63574

Comment 8 Fedora Update System 2017-05-26 06:02:08 UTC
cinnamon-3.4.1-1.fc25, cinnamon-desktop-3.4.1-1.fc25, cinnamon-settings-daemon-3.4.1-1.fc25, cinnamon-translations-3.4.2-1.fc25, cjs-3.4.1-1.fc25, nemo-3.4.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ae435e0c0

Comment 9 Fedora Update System 2017-05-26 11:39:52 UTC
cinnamon-3.4.1-1.fc25 cinnamon-desktop-3.4.1-1.fc25 cinnamon-session-3.4.0-6.fc25 cinnamon-settings-daemon-3.4.1-1.fc25 cinnamon-translations-3.4.2-1.fc25 cjs-3.4.1-1.fc25 nemo-3.4.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ae435e0c0

Comment 10 Fedora Update System 2017-05-26 11:41:26 UTC
cinnamon-3.4.1-1.fc26 cinnamon-desktop-3.4.1-1.fc26 cinnamon-session-3.4.0-6.fc26 cinnamon-settings-daemon-3.4.1-1.fc26 cinnamon-translations-3.4.2-1.fc26 cjs-3.4.1-1.fc26 nemo-3.4.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c08a63574

Comment 11 Fedora Update System 2017-05-26 19:35:01 UTC
cinnamon-3.4.1-1.fc26, cinnamon-desktop-3.4.1-1.fc26, cinnamon-session-3.4.0-6.fc26, cinnamon-settings-daemon-3.4.1-1.fc26, cinnamon-translations-3.4.2-1.fc26, cjs-3.4.1-1.fc26, nemo-3.4.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c08a63574

Comment 12 Fedora Update System 2017-05-27 04:39:23 UTC
cinnamon-3.4.1-1.fc25, cinnamon-desktop-3.4.1-1.fc25, cinnamon-session-3.4.0-6.fc25, cinnamon-settings-daemon-3.4.1-1.fc25, cinnamon-translations-3.4.2-1.fc25, cjs-3.4.1-1.fc25, nemo-3.4.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ae435e0c0

Comment 13 Fedora Update System 2017-05-31 23:04:04 UTC
cinnamon-3.4.1-2.fc25 cinnamon-desktop-3.4.1-1.fc25 cinnamon-session-3.4.0-6.fc25 cinnamon-settings-daemon-3.4.1-1.fc25 cinnamon-translations-3.4.2-1.fc25 cjs-3.4.1-1.fc25 nemo-3.4.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ae435e0c0

Comment 14 Fedora Update System 2017-05-31 23:06:08 UTC
cinnamon-3.4.1-2.fc26 cinnamon-desktop-3.4.1-1.fc26 cinnamon-session-3.4.0-6.fc26 cinnamon-settings-daemon-3.4.1-1.fc26 cinnamon-translations-3.4.2-1.fc26 cjs-3.4.1-1.fc26 nemo-3.4.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c08a63574

Comment 15 Fedora Update System 2017-06-01 18:05:29 UTC
cinnamon-3.4.1-2.fc25, cinnamon-desktop-3.4.1-1.fc25, cinnamon-session-3.4.0-6.fc25, cinnamon-settings-daemon-3.4.1-1.fc25, cinnamon-translations-3.4.2-1.fc25, cjs-3.4.1-1.fc25, nemo-3.4.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1ae435e0c0

Comment 16 Fedora Update System 2017-06-04 05:10:21 UTC
cinnamon-3.4.1-2.fc26, cinnamon-desktop-3.4.1-1.fc26, cinnamon-session-3.4.0-6.fc26, cinnamon-settings-daemon-3.4.1-1.fc26, cinnamon-translations-3.4.2-1.fc26, cjs-3.4.1-1.fc26, nemo-3.4.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1c08a63574

Comment 17 Fedora Update System 2017-06-09 11:29:14 UTC
cinnamon-3.4.1-2.fc25, cinnamon-desktop-3.4.1-1.fc25, cinnamon-session-3.4.0-6.fc25, cinnamon-settings-daemon-3.4.1-1.fc25, cinnamon-translations-3.4.2-1.fc25, cjs-3.4.1-1.fc25, nemo-3.4.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2017-06-09 19:10:26 UTC
cinnamon-3.4.1-2.fc26, cinnamon-desktop-3.4.1-1.fc26, cinnamon-session-3.4.0-6.fc26, cinnamon-settings-daemon-3.4.1-1.fc26, cinnamon-translations-3.4.2-1.fc26, cjs-3.4.1-1.fc26, nemo-3.4.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.