Bug 145292 - Kernel 2.6.10-1.741 breaks printer detection and setup ?
Kernel 2.6.10-1.741 breaks printer detection and setup ?
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-01-16 21:49 EST by Kim Lux
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-28 17:18:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kim Lux 2005-01-16 21:49:41 EST
Description of problem: Kudzu can't find printers with 2.6.10-1.741 
and print-gui won't properly set up a printer either.  
Version-Release number of selected component (if applicable): 
kernel 2.6.10-1.741 
printconf-gui: I can't find a version with rpm or with --help or with 
About on the application.  
rpm -q kudzu 
How reproducible: 
Tried to detect the printer about 10x; tried to install the driver 
half a dozen times.  
Steps to Reproduce: 
Situation A: kudzu doesn't detect 
1.Setup FC3 workstation with indicated components.  
2.Connect printer and run kudzu from command line or reboot.  (I'm 
using an Optra S 1855 printer.)    
3.Printer will not be detected by kudzu.  printerconf-gui will not 
find a printer attached to the parallel port.  At this point there is 
no way to make a printer work using kudzu and printerconf-gui.  
Situation B: printerconf-gui doesn't select the right driver 
1) Reboot with 2.6.9-1.681 
2) Kudzu will detect a printer 
3) Run printerconf-gui 
The following message will appear: 
No match for parallel port device: 
  mfr "Lexmark International" 
  model "Lexmark Optra S 1855" 
  desc "Lexmark Optra S 1855" 
  cmdset "PCL 6 Emulation, PostScript Level 2 Emulation, NPAP, PJL" 
Please report this message in Bugzilla: 
Choose 'foomatic' as the component. 
4) Manually select the following printer drivers in printerconf-gui, 
restarting each time: 
- optra S 1855 
- optra S 1250 
- Generic Postscript 
- PCL5 
- PCL6 
Printing doesn't work with any of these.  
Additional info: 
Here is an interesting twist: 
I have a laptop that printed with this very printer using a 
2.6.9-1.681 kernel without any problems.  It continued to print with 
that kernel.  It also printed with a 2.6.10-1.737 kernel.  It seems 
that only the detection of the printer and the installation of the 
driver is messed up with the 2.6.10-1.x kernels and that printing 
itself works OK.  
I wasted several hours of my time today trying to get printing 
working.  I am very frustrated that this problem made it into a 
general release FC3 kernel.
Comment 1 Myles Bogner 2005-01-22 01:14:22 EST
I appear to be having this problem or something very similar with
Fedora Core 2.  It began when upgrading to kernel-2.6.10-1.9_FC2 with
cups-1.1.20-11.10.  With kernel-2.6.8-1.521, my NEC Superscript 860
(parallel port) is detected fine and cups proceeds normally to load at
startup regardless whether the printer is actually on or not.  With
2.6.10, cups appears to hang indefinitely at boot regardless if the
printer is on or off.
Comment 2 Kim Lux 2005-02-09 16:12:36 EST
I've still got this problem with kernel 2.6.10-1.760.  For a number 
of reasons, I think this is a kudzu problem, not a kernel problem.  
Comment 3 Myles Bogner 2005-02-18 21:52:10 EST
I have upgraded to kernel-2.6.10-1.14_FC2 and
cups-1.1.20-11.11/cups-libs-1.1.20-11.11.  When booting
kernel-2.6.8-1.521, cups starts just fine.  When booting
kernel-2.6.10-1.14_FC2, cups hangs indefinitely.
Comment 4 Kim Lux 2005-06-27 17:54:43 EDT
This is kind of fixed in FC4.  Kudzu doesn't find the printer (or at least 
doesn't report it as new hardware found) and printer config-gui doesn't show 
the printer to be a Lexmark, but if one selects the lpr0  and sets the printer 
driver to Lexmark Optra S, it works.     
Comment 5 Myles Bogner 2005-06-28 11:39:07 EDT
For the problem I was reporting, I found that it is a duplicate of
Comment 6 Bill Nottingham 2005-09-28 17:18:58 EDT
As of kudzu-1.1.104-1, kudzu no longer configures printers (at the request of
the maintainers of the printer config tools.)  Hence, closing. 

Note You need to log in before you can comment on or make changes to this bug.