Bug 145295 - Autopackage support files into FC
Autopackage support files into FC
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
http://autopackage.org/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-16 22:28 EST by Fredrik Tolf
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 11:35:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fredrik Tolf 2005-01-16 22:28:10 EST
It would be nice to see that the autopackage support files would be
included in future FC releases, so that users could just install
.package files without worry.

Would that be possible?
Comment 1 Elliot Lee 2005-01-17 11:35:09 EST
Hi - thanks for the suggestion!

Anything is possible, but autopackage doesn't appear to fit with the
current thinking for Fedora Core, which uses rpm for its packaging
system and most likely will continue to use rpm only. autopackage also
doesn't look very mature. If you would like to have autopackage
available for Fedora, an alternative may be to become the maintainer
of an autopackage rpm in Fedora Extras, so that if someone does run
across a .package file, they can retrieve and install autopackage easily.
Comment 2 Fredrik Tolf 2005-01-18 07:02:22 EST
Oh, but autopackage is not thought of as an alternative to RPM.
Autopackage is meant to:
1. Allow users to install extra packages, whereas RPM seems to be more
of a system management kind of program.
2. Allow developers to distribute programs in a distro-independent way.
3. Allow users to install packages without having root privileges (in
~/.local).

Autopackage can also easily install its support files when the user
encounters his/her first package, since the package has a shell script
stub that can download it. That requires terminal access, however, so
it would be easier for GUI-only users if the support files were
already there.

Thus, it's merely for user convenience that I'd like to see the
autopackage support files installed by default, not as any kind of
change to the system itself.

Note You need to log in before you can comment on or make changes to this bug.