Bug 145296 - System Freezes Randomly (Bad page state at free_hot_cold_page (in process 'makewhatis'))
System Freezes Randomly (Bad page state at free_hot_cold_page (in process 'ma...
Status: CLOSED DUPLICATE of bug 114740
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-16 22:43 EST by John McCrae
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John McCrae 2005-01-16 22:43:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The system will freeze randomly, for no real reason, no apps need to
be running, computer becomes totally unresponsive, the only clue I
have is a message in /var/log/messages:
Jan 16 17:57:12 localhost kernel: Bad page state at free_hot_cold_page
(in process 'makewhatis', page 033542a0)
Jan 16 17:57:12 localhost kernel: flags:0x20000010 mapping:00000000
mapcount:34936762 count:0
Jan 16 17:57:12 localhost kernel: Backtrace:
Jan 16 17:57:12 localhost kernel:  [<02145ffb>] bad_page+0x5a/0x84
Jan 16 17:57:12 localhost kernel:  [<021517ba>] zap_pte_range+0x1b0/0x20e
Jan 16 17:57:12 localhost kernel:  [<021468b9>]
free_hot_cold_page+0x61/0xca
Jan 16 17:57:12 localhost kernel:  [<021517cb>] zap_pte_range+0x1c1/0x20e
Jan 16 17:57:12 localhost kernel:  [<0215185a>] zap_pmd_range+0x42/0x65
Jan 16 17:57:12 localhost kernel:  [<021518b9>] unmap_page_range+0x3c/0x5f
Jan 16 17:57:12 localhost kernel:  [<021519cd>] unmap_vmas+0xf1/0x1cc
Jan 16 17:57:12 localhost kernel:  [<02156d02>] exit_mmap+0xc8/0x1f0
Jan 16 17:57:12 localhost kernel:  [<0211d298>] mmput+0xb9/0xdc
Jan 16 17:57:12 localhost kernel:  [<02122b40>] do_exit+0x2be/0x767
Jan 16 17:57:12 localhost kernel:  [<0212319b>] sys_exit_group+0x0/0xd
Jan 16 17:57:12 localhost kernel: Trying to fix it up, but a reboot is
needed
(repeated 8 times at about 3 second intervals)

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Couldn't Reproduce


Additional info:

My best guess is that this has something to do with my SATA drive, as
this error sometimes cause corruption on my SATA partitions (although
my system actually runs of my IDE drive).
Comment 1 John McCrae 2005-02-09 10:07:57 EST

*** This bug has been marked as a duplicate of 114740 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.