Bug 1452979 - when using image id `openstack overcloud node configure` fail to configure new deploy-kernel and deploy-ramdisk
Summary: when using image id `openstack overcloud node configure` fail to configure ne...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Bob Fournier
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks: 1473267
TreeView+ depends on / blocked
 
Reported: 2017-05-21 12:31 UTC by Raviv Bar-Tal
Modified: 2018-06-27 13:33 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-common-8.3.1-0.20180123050219.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: The "openstack overcloud node configure" command would only take image names not image IDs for "deploy-kernel" and "deploy-ramdisk" parameters. Image IDs are now accepted after this fix.
Clone Of:
Environment:
Last Closed: 2018-06-27 13:31:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1710717 None None None 2017-08-14 21:14:51 UTC
OpenStack gerrit 498978 None MERGED Accept glance image ID in addition to name 2020-07-08 23:05:02 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:33:17 UTC

Description Raviv Bar-Tal 2017-05-21 12:31:29 UTC
Description of problem:
Try to configure nodes deployed kernel and ramdisk fails with error:
"Failed to configure nodes: [u'Kernel image not found in Glance, and no path specified.']"

NOTE: 1. The id is valid and appear in `openstack image list \ show`
      2. using image name instead of ID works.

Version-Release number of selected component (if applicable):


How reproducible:
Try to configure new deploye-kernel/ramdisk

Steps to Reproduce:
1. upload now images
2. run the command ` openstack overcloud node configure  --deploy-kernel ID --deploy-ramdisk ID compute-0
3.

Actual results:
command fails

Expected results:
command pass 

Additional info:

sosreport is attached

Comment 1 Bob Fournier 2017-08-14 21:14:20 UTC
Yes it looks like only the name is being used when checking the images, not the ID.
I opened an upstream bug here:https://bugs.launchpad.net/tripleo/+bug/1710717

The code is here: tripleo_common/utils/glance.py", line 78, in _upload_file

Comment 6 Alexander Chuzhoy 2018-05-07 15:52:28 UTC
Verified:

Environment: openstack-tripleo-common-8.6.1-6.el7ost.noarch




(undercloud) [stack@undercloud-0 ~]$  ironic node-create --name my-vm.5 -d ipmi
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+----------------------+--------------------------------------+
| Property             | Value                                |
+----------------------+--------------------------------------+
| boot_interface       | pxe                                  |
| chassis_uuid         | None                                 |
| console_interface    | ipmitool-socat                       |
| deploy_interface     | iscsi                                |
| driver               | ipmi                                 |
| driver_info          | {}                                   |
| extra                | {}                                   |
| inspect_interface    | inspector                            |
| management_interface | ipmitool                             |
| name                 | my-vm.5                              |
| network_interface    | flat                                 |
| power_interface      | ipmitool                             |
| properties           | {}                                   |
| raid_interface       | no-raid                              |
| resource_class       | baremetal                            |
| storage_interface    | noop                                 |
| uuid                 | ebe28c51-7f4e-418c-b093-41b2436407b1 |
| vendor_interface     | ipmitool                             |
+----------------------+--------------------------------------+
(undercloud) [stack@undercloud-0 ~]$ ironic node-show my-vm.5
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+------------------------+--------------------------------------+
| Property               | Value                                |
+------------------------+--------------------------------------+
| boot_interface         | pxe                                  |
| chassis_uuid           | None                                 |
| clean_step             | {}                                   |
| console_enabled        | False                                |
| console_interface      | ipmitool-socat                       |
| created_at             | 2018-05-07T15:44:01+00:00            |
| deploy_interface       | iscsi                                |
| driver                 | ipmi                                 |
| driver_info            | {}                                   |
| driver_internal_info   | {}                                   |
| extra                  | {}                                   |
| inspect_interface      | inspector                            |
| inspection_finished_at | None                                 |
| inspection_started_at  | None                                 |
| instance_info          | {}                                   |
| instance_uuid          | None                                 |
| last_error             | None                                 |
| maintenance            | False                                |
| maintenance_reason     | None                                 |
| management_interface   | ipmitool                             |
| name                   | my-vm.5                              |
| network_interface      | flat                                 |
| power_interface        | ipmitool                             |
| power_state            | None                                 |
| properties             | {}                                   |
| provision_state        | enroll                               |
| provision_updated_at   | None                                 |
| raid_config            | {}                                   |
| raid_interface         | no-raid                              |
| reservation            | None                                 |
| resource_class         | baremetal                            |
| storage_interface      | noop                                 |
| target_power_state     | None                                 |
| target_provision_state | None                                 |
| target_raid_config     | {}                                   |
| traits                 |                                      |
| updated_at             | None                                 |
| uuid                   | ebe28c51-7f4e-418c-b093-41b2436407b1 |
| vendor_interface       | ipmitool                             |
+------------------------+--------------------------------------+


(undercloud) [stack@undercloud-0 ~]$ openstack image list
+--------------------------------------+------------------------+--------+
| ID                                   | Name                   | Status |
+--------------------------------------+------------------------+--------+
| 8805cb89-215a-4253-9688-00993d65648e | bm-deploy-kernel       | active |
| b9a5615a-3f9c-415c-97c7-603b8cf0b9d6 | bm-deploy-ramdisk      | active |
| e467b9d8-d59f-47fc-93a9-10802a2b633e | overcloud-full         | active |
| b9044a69-e9ac-42fe-b208-ffad642504ae | overcloud-full-initrd  | active |
| a3ce950d-b5db-4b85-9c10-433d8f1854eb | overcloud-full-vmlinuz | active |
+--------------------------------------+------------------------+--------+


(undercloud) [stack@undercloud-0 ~]$  openstack overcloud node configure  --deploy-kernel 8805cb89-215a-4253-9688-00993d65648e --deploy-ramdisk b9a5615a-3f9c-415c-97c7-603b8cf0b9d6 my-vm.5
Started Mistral Workflow tripleo.baremetal.v1.configure. Execution ID: 31326cac-03cb-4aa4-8e4e-d8a5ce86cc09
Waiting for messages on queue 'tripleo' with no timeout.
Successfully configured the nodes.
(undercloud) [stack@undercloud-0 ~]$ ironic node-show my-vm.5
The "ironic" CLI is deprecated and will be removed in the S* release. Please use the "openstack baremetal" CLI instead.
+------------------------+--------------------------------------------------------------+
| Property               | Value                                                        |
+------------------------+--------------------------------------------------------------+
| boot_interface         | pxe                                                          |
| chassis_uuid           | None                                                         |
| clean_step             | {}                                                           |
| console_enabled        | False                                                        |
| console_interface      | ipmitool-socat                                               |
| created_at             | 2018-05-07T15:44:01+00:00                                    |
| deploy_interface       | iscsi                                                        |
| driver                 | ipmi                                                         |
| driver_info            | {u'deploy_ramdisk': u'b9a5615a-3f9c-415c-97c7-603b8cf0b9d6', |
|                        | u'deploy_kernel': u'8805cb89-215a-4253-9688-00993d65648e'}   |
| driver_internal_info   | {}                                                           |
| extra                  | {}                                                           |
| inspect_interface      | inspector                                                    |
| inspection_finished_at | None                                                         |
| inspection_started_at  | None                                                         |
| instance_info          | {}                                                           |
| instance_uuid          | None                                                         |
| last_error             | None                                                         |
| maintenance            | False                                                        |
| maintenance_reason     | None                                                         |
| management_interface   | ipmitool                                                     |
| name                   | my-vm.5                                                      |
| network_interface      | flat                                                         |
| power_interface        | ipmitool                                                     |
| power_state            | None                                                         |
| properties             | {u'capabilities': u'boot_option:local'}                      |
| provision_state        | enroll                                                       |
| provision_updated_at   | None                                                         |
| raid_config            | {}                                                           |
| raid_interface         | no-raid                                                      |
| reservation            | None                                                         |
| resource_class         | baremetal                                                    |
| storage_interface      | noop                                                         |
| target_power_state     | None                                                         |
| target_provision_state | None                                                         |
| target_raid_config     | {}                                                           |
| traits                 |                                                              |
| updated_at             | 2018-05-07T15:50:51+00:00                                    |
| uuid                   | ebe28c51-7f4e-418c-b093-41b2436407b1                         |
| vendor_interface       | ipmitool                                                     |
+------------------------+--------------------------------------------------------------+

Comment 8 errata-xmlrpc 2018-06-27 13:31:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.