Bug 1453 - Breach of license of many TeX/LaTeX packages by omission of required source code
Breach of license of many TeX/LaTeX packages by omission of required source code
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
5.2
All Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-08 11:58 EST by david.kastrup
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-31 15:34:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.kastrup 1999-03-08 11:58:34 EST
I have acquired the variety pack of RedHat 5.2, and with
distress and unbelief have noticed that in a crass breach of
all LaTeX licenses, the source code to the texmf tree is not
present, neither on the i386 specific CD, nor on the SRPMS
CD.

I have searched all the available RPMs, to no avail.  For
your information:  a working teTeX can be compiled by using
the archive files teTeX-src-0.9-xxx (for compiling all
binaries needed) and the texmf-tree available from
teTeX-texmf-0.9-xxx.  This is what is present in the Source
RPM file of teTeX you deliver.

But this does not contain any of the TeX/LaTeX sources from
which the texmf tree has been compiled and extracted.
*Those* are in tetex-texmfsrc-0.9-xxx which has not found
its way anywhere onto your CDs.  These sources are important
for anyone that wants to locate and report bugs in the
accompanying LaTeX styles and packages, or wants to use them
as additional information.

I would *strongly* recommend that you include this package
as a noarch package.  An SRPM does not really make much
sense since the regular process of preparing a teTeX
distribution (by anyone except Thomas Esser) does not need
to convert this source tree into the corresponding texmf
tree.  I am not entirely sure whether there is a completely
automated procedure to generate the teTeX texmf tree from
the teTeX texmfsrc package.  If there is, and you are short
on CDROM space, you should probably package only texmfsrc in
your SRPM (including apporpriate build procedures) instead
of the compiled texmf tree.

Distributing extracted LaTeX files without these sources is
illegal. I have not yet notified either Thomas Esser as the
author of teTeX nor the LaTeX team about this breach of
license, since I feel that it might be in the best interest
of all parties involved if you just fixed this for the next
release amiably *before* a stink gets raised. I am pretty
sure that this ommision has been more or less by accident.
If people find out that you have failed to include the stuff
on later releases, but by now do, I guess few will complain.
Of course, I would not mind if you sent me the sources which
you have omitted from my RedHat 5.2 CD (and which still are
missing from Rawhide, as far as I could notice) on a
separate CD, so that I will not have to download 12MB that
ought to have been included in my purchase in the first
place.  If you won't have such a CD ready until the stuff
gets put on RedHat 6.0 CDs, I am willing to wait that
long...

All the best
Comment 1 Mike Maher 1999-03-10 14:13:59 EST
These sources are included.  You must look in /usr/share/tetex/
After doing diffs with the said package they are the same.
Comment 2 Cristian Gafton 1999-03-10 20:00:59 EST
As far as I know latex is licensed under GPL. We packaged the original
source files we used to produce the binary packages in the src.rpm
found on the SRPMS. GPL requires us to ship all the sources used in
building a package. For the purpose of this packages, precompiled
binary fonts and styles packages separately are used as *sources*
because they are available from the CTAN sites.

I doubt that this is a breach of the license


------- Email Received From  David Kastrup <dak@neuroinformatik.ruhr-uni-bochum.de> 03/11/99 04:53 -------
Comment 3 david.kastrup 1999-03-15 17:05:59 EST
As you have discarded bug report #1453 in spite of me explaining in
several Emails (see the entries in Bug #1453 email) that went largely
ignored how you were in conflict with the various copyrights, I have
notified Thomas Esser, the author of teTeX, of the situation.  You can
contact him at te@informatik.uni-hannover.de if you still do not
understand the implications of the GPL and the LaTeX licenses.  As one
reaction, he will be putting up a README shortly specifically for
distributors that can't be bothered to either read or understand the
licenses of the various files comprising teTeX at the teTeX ftp site.

If you still choose to be in breach of the copyright on the entire
LaTeX source distribution as detailed in the email I have already
written on this matter, I will also notify the LaTeX project as main
copyright holder on those pieces of software the license of which you
choose to violate of your unwillingness to comply with the LaTeX
distribution terms, and of your frivolous claim that the LaTeX source
files are "font files", you do not consider complying with "font file
licenses", anyhow, and that whoever wants to get the sources can get
them elsewhere.

I find it pretty disappointing to hear such a stance from RedHat,
which I had previously considered to be a party more interested in
adhering to the licenses of free software.
Comment 4 Cristian Gafton 1999-03-31 15:34:59 EST
The current source rpm for tetx includes the latex texmfsrc tar
archive if anybody wants to use it.

Note You need to log in before you can comment on or make changes to this bug.