Bug 1453003 - [abrt] dnfdragora-gui: __shutdown(): updater.py:92:__shutdown:TypeError: 'list' object is not callable
Summary: [abrt] dnfdragora-gui: __shutdown(): updater.py:92:__shutdown:TypeError: 'lis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0f5620636b2d8b05b210a1950c5...
: 1568673 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-21 20:07 UTC by Joseph D. Wagner
Modified: 2018-04-18 04:54 UTC (History)
7 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:26:35 UTC


Attachments (Terms of Use)
File: backtrace (748 bytes, text/plain)
2017-05-21 20:07 UTC, Joseph D. Wagner
no flags Details
File: cgroup (289 bytes, text/plain)
2017-05-21 20:07 UTC, Joseph D. Wagner
no flags Details
File: cpuinfo (1012 bytes, text/plain)
2017-05-21 20:07 UTC, Joseph D. Wagner
no flags Details
File: environ (1.34 KB, text/plain)
2017-05-21 20:07 UTC, Joseph D. Wagner
no flags Details
File: mountinfo (3.04 KB, text/plain)
2017-05-21 20:07 UTC, Joseph D. Wagner
no flags Details
File: namespaces (102 bytes, text/plain)
2017-05-21 20:08 UTC, Joseph D. Wagner
no flags Details
File: open_fds (1.04 KB, text/plain)
2017-05-21 20:08 UTC, Joseph D. Wagner
no flags Details

Description Joseph D. Wagner 2017-05-21 20:07:48 UTC
Description of problem:
I right-clicked the icon, and clicked exit.

Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: __shutdown
exception_type: TypeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.12.0-0.rc1.git1.1.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
updater.py:92:__shutdown:TypeError: 'list' object is not callable

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 236, in inner
    callback(self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 320, in __call__
    return self._action(icon, self)
  File "/usr/lib/python3.6/site-packages/pystray/_base.py", line 414, in wrapper1
    return action(icon)
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 92, in __shutdown
    for task in self.__scheduler.queue():
TypeError: 'list' object is not callable

Local variables in innermost frame:
kwargs: (<pystray._gtk.Icon object at 0x7fbca9b88dd8>,)
self: <dnfdragora.updater.Updater object at 0x7fbccb90e5c0>

Comment 1 Joseph D. Wagner 2017-05-21 20:07:54 UTC
Created attachment 1280822 [details]
File: backtrace

Comment 2 Joseph D. Wagner 2017-05-21 20:07:55 UTC
Created attachment 1280823 [details]
File: cgroup

Comment 3 Joseph D. Wagner 2017-05-21 20:07:56 UTC
Created attachment 1280824 [details]
File: cpuinfo

Comment 4 Joseph D. Wagner 2017-05-21 20:07:58 UTC
Created attachment 1280825 [details]
File: environ

Comment 5 Joseph D. Wagner 2017-05-21 20:07:59 UTC
Created attachment 1280826 [details]
File: mountinfo

Comment 6 Joseph D. Wagner 2017-05-21 20:08:00 UTC
Created attachment 1280827 [details]
File: namespaces

Comment 7 Joseph D. Wagner 2017-05-21 20:08:01 UTC
Created attachment 1280828 [details]
File: open_fds

Comment 8 Jan Kurik 2017-08-15 06:16:12 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 9 r.simons 2017-11-23 07:21:28 UTC
Similar problem has been detected:

I wanted to shutdown dnfdragora by right clicking the item in the menu bar (on cinnamon) and then pressing "Exit"

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: __shutdown
exception_type: TypeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.12-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         updater.py:92:__shutdown:TypeError: 'list' object is not callable
runlevel:       N 5
type:           Python3
uid:            1000

Comment 10 Fedora Update System 2017-12-29 23:20:12 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 11 Fedora Update System 2017-12-29 23:26:12 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 12 Fedora Update System 2017-12-30 19:53:07 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 13 Fedora Update System 2017-12-30 20:38:55 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 14 Fedora Update System 2017-12-31 21:26:35 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-01-01 22:10:19 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 zethan191 2018-04-18 04:54:23 UTC
*** Bug 1568673 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.