Bug 145305 - /var/log/lastlog very large size after install
/var/log/lastlog very large size after install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 04:27 EST by Per Steinar Iversen
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 14:26:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2005-01-17 04:27:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041220 Fedora/1.7.5-1

Description of problem:
After installing an x86_64 system /var/log/lastlog is a huge file:

-r--------   1 root     root     1254130450140 Jan 14 12:25 lastlog

Since this file is much larger than the disk capacity of the system it
is clearly a sparse file.

I have reinstalled and checked with "linux rescue" and the same huge
file is there before the very first boot.

Not all utilities handle such huge sparse files well. Deleting this
file and creating a new one works well.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install x86_64
2. A huge file is installed as /var/log/lastlog
3.
    

Actual Results:  /var/log/lastlog is very large, surely a sparse file.

Expected Results:  /var/log/lastlog should be zero or quite small
before the first login.

Additional info:

Hardware: AMD64 3500+, ASUS A8V Deluxe motherboard, 2x200GB SATA disks
in MD1 software RAID for the filesystems.
Comment 1 Bill Nottingham 2005-01-17 14:26:02 EST
It's a sparse file, it's because of the userid for nfsnobody.

Note You need to log in before you can comment on or make changes to this bug.