Bug 145337 - nanosleep from 32 bit process return EINVAL instead of EINTR
nanosleep from 32 bit process return EINVAL instead of EINTR
Status: CLOSED DUPLICATE of bug 145338
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: compat-glibc (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 11:25 EST by john yates
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 11:56:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john yates 2005-01-17 11:25:46 EST
Description of problem:

(Component is just a guess)

Executing nanosleep from a 32-bit returns wrong value in errno when interrupted 
by a signal (EINVAL instead of EINTR).  For quick reference here is man page 
description:

====

In case of an error or exception, the nanosleep system call returns -1 instead 
of 0 and sets errno to one of the following values:

EINTR 
The pause has been interrupted by a non-blocked signal that was delivered to 
the process. The remaining sleep time has been written into *rem so that the 
process can easily call nanosleep again and continue with the pause. 

EINVAL 
The value in the tv_nsec field was not in the range 0 to 999 999 999 or tv_sec 
was negative. 
  

Version-Release number of selected component (if applicable):


How reproducible:

Run repro.sh from attached archive.

Actual results:

errno is EINVAL

Expected results:

errno should be EINTR

Additional info:
Comment 1 john yates 2005-01-17 11:29:51 EST
Mea culpa!  This was my first attempt to submit a bug.  The attachment was 
missing.  I now understand that I could add it later.  145338 is the same bug 
with the repro file attached.
Comment 2 Jakub Jelinek 2005-01-17 11:56:09 EST

*** This bug has been marked as a duplicate of 145338 ***

Note You need to log in before you can comment on or make changes to this bug.