Bug 145343 - Spontaneously can't fork() as/setuid() to a specific user
Spontaneously can't fork() as/setuid() to a specific user
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 12:27 EST by Nils Philippsen
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-26 07:10:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2005-01-17 12:27:09 EST
Description of problem:

Spontaneously, I couldn't fork() (well, clone(), when running an external
program from a running bash) as my user or setuid() (when running su) to my user
anymore. The system calls return EAGAIN which indicates it runs against
RLIMIT_NPROC, but this can't really be as there are only a couple of processes
running (about 20, both soft and hard limits are 8191 on that machine). When I
kill all processes of that user on the machine, things are back to normal. Maybe
something corrupts the RLIMIT_NPROCS setting.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3
kernel-2.6.10-1.741_FC3

How reproducible:
Sometimes

Steps to Reproduce:
? -- If I experience it again, maybe I can find a apattern, but I'm not sure
about it now.
  
Actual results:
clone() from user, setuid() to user fail with EAGAIN. Other users are fine.

Expected results:
clone(), setuid() work
Comment 1 Nils Philippsen 2005-03-08 05:15:42 EST
Problem persists on kernel-2.6.10-1.770_FC3.

Processes running when the problem happened this time:

--- 8< ---
root@wombat:~> pgrep -u nils -l
16782 ssh-agent
16866 gconfd-2
17109 gam_server
20771 spamd
20773 spamd
20774 spamd
20775 spamd
20776 spamd
20777 spamd
21490 esd
--- >8 ---
Comment 2 Dave Jones 2005-07-15 15:15:12 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Nils Philippsen 2005-07-26 07:10:40 EDT
Doesn't seem to happen anymore with recent FC4 kernels.

Note You need to log in before you can comment on or make changes to this bug.