Bug 14535 - inn-2.2.2-7 doesn't expire overview database!
inn-2.2.2-7 doesn't expire overview database!
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: inn (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 11:44 EDT by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 09:36:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2000-07-24 11:44:09 EDT
/etc/cron.daily/inn-cron-expire in inn-2.2.2-7 doesn't specify "expireover"
on the news.daily command line, so overview database files are never
expired, i.e., they list every single article that ever passed through the
server, even articles that have long since expired.  Hence, nnrpd has lots
of delays while it parses huge overview files with lots of useless data in
them.
Comment 1 Philip Rowlands 2000-08-07 09:30:06 EDT
My version of INN (inn-2.2.2-3) documents the 'delayrm' option as implicitly
specifying 'expireover'; therefore the supplied inn-cron-expire *does* call
expireover.

Read news.daily(8) - I may well be wrong about later versions.
Comment 2 Jonathan Kamens 2000-08-07 09:36:24 EDT
You will see from reading the code in news.daily that the "delayrm" option does
not, in fact, cause expireover to be invoked.

This means that either the man page is correct and there's a bug in news.daily,
or news.daily is correct and then man page is wrong.

In any case, this bug stands :-).
Comment 3 Florian La Roche 2000-08-07 10:08:48 EDT
The current inn package shouldn't create any overview files so they also don't
have to be cleaned up. :-)

I will enable that in "newsfeeds" and will then also change the cron job to
expire overview
files in the near future.

Note You need to log in before you can comment on or make changes to this bug.