Bug 145353 - man displays garbled characters with en_US.UTF-8
Summary: man displays garbled characters with en_US.UTF-8
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: groff (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-17 18:28 UTC by B Wooster
Modified: 2013-07-02 23:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-19 01:32:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description B Wooster 2005-01-17 18:28:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=83017
says a similar bug was closed, this is probably related to the same
problem.

Single and double quote characters, as well as grave accents, don't
display correctly when I do use man from a ssh shell (TERM is vt100 or
vt320).
It displays correctly under a KDE term (konsole).

A workaround:

$ LANG=en_us man groff
will display the text for the -N option (word "Don't"), the -P option
correctly.


Version-Release number of selected component (if applicable):
groff-1.18.1.1-3

How reproducible:
Always

Steps to Reproduce:
1. run:   LANG=en_US.UTF-8 man groff
2. look at any word with single quote, double quote or grave accent
3.
    

Actual Results:  The -N section reads: Donât instead of Don't...


Expected Results:  word should read: Don't

Additional info:

Comment 1 B Wooster 2005-01-17 18:37:57 UTC
The actual results paragraph above seems to show the word don't
correctly on the web page - but the word is garbled in a VT100
terminal, here's what it looks like, hope this shows up as correctly
(showing  the wrong characters!)

Don't
ends up displaying as:
Donââ¬â¢t

Here's the octal dump:
D   o   n 342 200 231   t [octal]
D   o   n 226 128 153   t [decimal]


Comment 2 B Wooster 2005-01-19 01:34:16 UTC
Changed to not-a-bug, just discovered that the problem is with the
TerraTerm SSH terminal, which can't handle UTF-8 text - not only man,
but slrn, mutt, etc all break, so this is nothing to do with groff.


Comment 3 Jindrich Novy 2005-01-19 08:44:13 UTC
Hello B,

thanks for the investigation. I'm happy it's not a fault of groff
after all ;)

cheers,
Jindrich


Note You need to log in before you can comment on or make changes to this bug.