Bug 145362 - wget --exclude-directories option is ignored.
wget --exclude-directories option is ignored.
Status: CLOSED DUPLICATE of bug 124867
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 14:13 EST by Niels Basjes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels Basjes 2005-01-17 14:13:51 EST
Description of problem:
The -X (--exclude-directories) option is ignored on wget 1.9.1.
Current workaround (for me): Use wget 1.8 from Fedora Core 1 and
fiddle with the options so yum won't update it.

Version-Release number of selected component (if applicable):
wget-1.9.1-17

How reproducible:
Always

Steps to Reproduce:
1. Do this:  wget -nv -r -N -l inf -X
\*SRPMS\*,\*debug\*,\*testing\*,\*iso\*,\*ia64\*,\*x86_64\*,\*test\*,\*development\*
 ftp://download.fedora.redhat.com/pub/fedora/3/i386/os/
2.
3.
  
Actual results:
The entire tree is downloaded

Expected results:
The specified parts should have been skipped.

Additional info:
This bug has already been reported on FC2 (Bug 124867) but has _not_
been fixed yet.
Comment 1 Karsten Hopp 2005-01-18 06:44:21 EST
Please don't open a new bugreport then, just add a comment to bug
124867 that this bug still exists with the new release

*** This bug has been marked as a duplicate of 124867 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.