Bug 145366 - yumRepo.py calls undefined function '_'
yumRepo.py calls undefined function '_'
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 14:44 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 17:15:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2005-01-17 14:44:43 EST
Description of problem:
If there's an error downloading a header for a yum repository, up2date
will attempt to print a translated error, but because it has not
imported the string translation function.  Based on other modules,
adding this to the top should fix it:
  from rhpl.translate import _, N_

Version-Release number of selected component (if applicable):
4.3.69-1

How reproducible:
Always

Steps to Reproduce:
1. Configure up2date to use yum repository
http://fedoraproject.org/pre-extras/3/i386/
2. Attempt to install a package from the repository which requires at
least one other package from the repository.
3. A bogus entry in the header.info file will trigger the error.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adrian Likins 2005-01-17 17:15:52 EST
already fixed in 4.4.x

Note You need to log in before you can comment on or make changes to this bug.