Bug 145371 - optional auth should be loadable module in sub-package
optional auth should be loadable module in sub-package
Status: CLOSED DUPLICATE of bug 145241
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Depends On:
  Show dependency treegraph
Reported: 2005-01-17 15:25 EST by John Dennis
Modified: 2014-01-21 17:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-23 04:07:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description John Dennis 2005-01-17 15:25:27 EST
This is bug to make sure the issue in bug #145241 gets resolved.

The postgres and mysql support (plus any other optional auth) should
be built as loadable modules as described in the dovecot INSTALL doc
file. Then these modules should be provided as sub-packages.

The rational is dovecot should be lightweight and not have heavy
external dependencies. If a site wants the optional mechanisms then
they can install an appropriate sub-package that provides a loadable
module with the support and only then will there be a dependency on
external packages.
Comment 1 Petr Rockai 2006-01-23 04:07:09 EST
Since all the discussion happened in bug #145241, i am closing this one as a 
dupe and retitling the former to better describe the problem at hand. 

*** This bug has been marked as a duplicate of 145241 ***

Note You need to log in before you can comment on or make changes to this bug.