Bug 145412 - konqueror unable to access 'localhost' on alias directive in httpd.conf
konqueror unable to access 'localhost' on alias directive in httpd.conf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-17 22:43 EST by Scott R. Godin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-23 08:51:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing kde failing to load localhost on an alias directive (274.70 KB, image/jpeg)
2005-01-17 22:45 EST, Scott R. Godin
no flags Details
firefox correctly accessing both localhost and 127.0.0.1 on the aliased directory (233.66 KB, image/jpeg)
2005-01-17 22:46 EST, Scott R. Godin
no flags Details

  None (edit)
Description Scott R. Godin 2005-01-17 22:43:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After setting up a directory in my home dir, to proof test some
website work, via Alias directive in httpd.conf, I discovered while
testing the 'site' that while konqueror is able to access it via
http://127.0.0.1/dir/ it was unable to access it via http://localhost/

Firefox is perfectly capable of accessing it either way. 

I've got two screenshots (one showing firefox, and the other showing
konqueror, along with the directives in the httpd.conf that were used,
in the background open in gvim) illustrating the problem, that I will
attach to this report.

Version-Release number of selected component (if applicable):
kdebase-3.3.1-4.3.FC3

How reproducible:
Always

Steps to Reproduce:
1. open up httpd.conf and Alias /somedir/ /home/username/somedir/html/
and then add 
<Directory "/home/webadmin/madhouse/html">
    Options Indexes Multiviews
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.1
</Directory>

2. put a test.htm in /home/username/somedir/html/
3. attempt to access http://localhost/somedir/test.htm
    

Actual Results:  konqueror is unable to access
/home/$USER/dir/html/file.htm via localhost, only 127.0.0.1

Expected Results:  'localhost' should work equally as well as 127.0.0.1 

Additional info:

none of KDE was installed at the time I decided to test in konqueror,
(I've been using xfce mostly), so I did ( yum install kdebase
kdebase-devel kdeaddons) which additionally slurped in kdelibs
kdemultimedia kdelibs-devel kdepim. No kde settings have yet been
changed; it is as-is including anything in updates-released since
FC3's release.
Comment 1 Scott R. Godin 2005-01-17 22:45:19 EST
Created attachment 109909 [details]
screenshot showing kde failing to load localhost on an alias directive
Comment 2 Scott R. Godin 2005-01-17 22:46:50 EST
Created attachment 109910 [details]
firefox correctly accessing both localhost and 127.0.0.1 on the aliased directory

you will note from the previous screenshot, however that http://localhost/ DOES
work in Konqueror, it only fails on the aliased directory, which is strange.
Comment 3 Scott R. Godin 2005-01-17 22:49:37 EST
As you can see, the directory permissions are all functionally correct
to allow access. 

10:48pm {43} localhost:/home/webadmin>$ ll -d .
drwx--x--x  71 webadmin users 4096 Jan 17 22:40 ./
10:48pm {44} localhost:/home/webadmin>$ ll -d madhouse/
drwxr-xr-x  4 webadmin users 4096 Jan 12 12:43 madhouse//
10:48pm {45} localhost:/home/webadmin>$ ll -d madhouse/html/
drwxr-xr-x  3 webadmin users 4096 Jan 17 14:12 madhouse/html//
10:48pm {46} localhost:/home/webadmin>$ ll -d
madhouse/html/subscribe_basic.htm
-rw-r--r--  1 webadmin users 6566 Jan 17 14:12
madhouse/html/subscribe_basic.htm
Comment 4 Scott R. Godin 2005-01-17 22:53:40 EST
obviously the Directory directive above should read 

<Directory "/home/username/somedir/html">

and not what I actually used, and pasted in, and forgot to 'dumb down
for example purposes', and I seriously wish Bugzilla would let me edit
my original post. *grumble* :) 
Comment 5 Ngo Than 2005-01-23 08:51:47 EST
It's not a bug in konqueror, but in your setting. it works fine for me
with this entry in httpd.conf

Alias /madhouse/ "/home/webadmin/madhouse/html/"
<Directory "/home/webadmin/madhouse/html">
    Options Indexes Multiviews
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.1
</Directory>


please check your config again. please read apache manuall!


Note You need to log in before you can comment on or make changes to this bug.