Bug 145431 - [bn_IN] backspace changes independent indic characters
Summary: [bn_IN] backspace changes independent indic characters
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pango
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Behdad Esfahbod
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: Indic 220805
TreeView+ depends on / blocked
 
Reported: 2005-01-18 13:03 UTC by Jatin Nansi
Modified: 2009-07-07 09:07 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-07-07 09:07:37 UTC


Attachments (Terms of Use)
screenshot of gedit (23.44 KB, image/png)
2005-01-18 13:04 UTC, Jatin Nansi
no flags Details

Description Jatin Nansi 2005-01-18 13:03:15 UTC
Description of problem:
when backspace key is hit after a consonant with a dot at the bottom,
the dot vanishes and the result is an independent and unrelated
alphabet. The dot in this case is not a vowel sign, it is a part of
the consonant itself. 
The 1st example is of Bengali Yaa - <09DF>. A backspace changes it to
a bengali Ya - <09AF>.
See attached image for example. The image uses the bengali probhat
keyboard layout.


Version-Release number of selected component (if applicable):
1.6.0-7


How reproducible:
Every time


Steps to Reproduce:
1. Start gedit in bengali locale
2. Ctrl+space, F6
3. press 'z' then bkspace
  
Actual results:
The 'dot' below the yaa character gets deleted, and it becomes a ya.


Expected results:
The complete yaa character should get deleted.


Additional info:
Tested on RHEL4-RC-0107.0 WS

Comment 1 Jatin Nansi 2005-01-18 13:04:31 UTC
Created attachment 109923 [details]
screenshot of gedit

Comment 2 Leon Ho 2005-05-16 05:01:17 UTC
Are there any plan this this entry?

Comment 3 Matthias Clasen 2006-06-20 05:12:17 UTC
Reassigning pango bugs to Behdad.

Comment 4 Liang Zhang 2006-07-20 09:43:22 UTC
I debug this bug and I find that this bug is not the bug of Pango, but the bug
of gtk. 
gtk_entry_backspace( ) and gtk_text_buffer_backspace( ) need be modified.
I will write a patch for this bug.
I filed a new bug of gtk in Gnome bugzilla.
http://bugzilla.gnome.org/show_bug.cgi?id=348107

Comment 5 Liang Zhang 2006-07-21 03:05:37 UTC
I wrote a patch for this bug.
The patch is below:
http://bugzilla.gnome.org/show_bug.cgi?id=348107

Comment 6 Satyabrata Maitra 2006-12-20 12:03:33 UTC
Problem still exists in RHEL5 Beta. 

Component Version tested :
pango-1.14.9-3.el5.

Package available in the tree :
http://porkchop.redhat.com/nightly/RHEL5-Client-20061218.nightly/tree-i386/Client/

tested this bug with EL4 also. there tested it with the Component Version :
pango-1.6.0-9.2. Bug is also exists there in EL4.

If any rpm or test RPM available to test the patch mentioned in comment #5, pls
attach it, so that i can test the work done fixing this problem.

Comment 7 Behdad Esfahbod 2006-12-20 18:29:54 UTC
LingNing, any update here?

Comment 8 Liang Zhang 2006-12-31 02:40:18 UTC
I wrote a patch for fixing this bug and bug217017, bug220805. And this patch
fixed all problems about backspace-delete and cursor moving of all split matras
of all indic scripts.
The patch is:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217017

Comment 9 Jens Petersen 2008-05-01 00:38:50 UTC
Rahul, can you review the status of this?

Comment 10 Rahul Bhalerao 2008-05-01 09:41:54 UTC
This behavior is due to the Normalization. And as seen on the comments on
upstream bugs, backspace on NFD, is actually an expected behavior. So since this
is what Unicode expects, I am not sure if this should be treated as a bug. 


Note You need to log in before you can comment on or make changes to this bug.