Bug 145435 - kernel: [drm:i830_ioremapfree:mappings] *ERROR* Excess frees:
Summary: kernel: [drm:i830_ioremapfree:mappings] *ERROR* Excess frees:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Martuccelli
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-18 14:21 UTC by Mikael M. Hansen
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-01-23 19:14:15 UTC


Attachments (Terms of Use)

Description Mikael M. Hansen 2005-01-18 14:21:08 UTC
Description of problem:
When a RHEL3 (Upd 2-4) host has been running for a few days while a
person is logged in on the console (X) and logout the screen goes
blank and the following keeps appearing between attempts to start X again.

Jan 17 04:04:03 scenic32 kernel:[drm:i830_ioremapfree:mappings]*ERROR*
Excess frees: 5062233 frees, 98511 allocs 
Jan 17 04:04:03 scenic32 kernel: [drm:i830_ioremapfree:mappings]
*ERROR* Attempt to free NULL pointer 
Jan 17 04:04:03 scenic32 kernel: [drm:i830_ioremapfree:mappings]
*ERROR* Excess frees: 5062234 frees, 98511 allocs 
Jan 17 04:04:03 scenic32 kernel: [drm:i830_ioremapfree:mappings]
*ERROR* Attempt to free NULL pointer 
Jan 17 04:04:03 scenic32 kernel: [drm:i830_ioremapfree:mappings]
*ERROR* Excess frees: 5062235 frees

etc.

I suppose it has somethin to do with the i830 module (drm).

Version-Release number of selected component (if applicable):

# modinfo i830
filename:   /lib/modules/2.4.21-27.0.1.EL/kernel/drivers/char/drm/i830.o
description: "Intel 830M"
author:      "VA Linux Systems Inc."
license:     "GPL and additional rights"
parm:        drm_opts string


How reproducible:
It has been consistant for 6 month (in both RHEL3 upd2, upd3 and upd4)

Steps to Reproduce:
1. Login (x) use the host for nomal operations. Activate the
screensaver at night
2. Logout after a few days
3.
  
Actual results:


Expected results:


Additional info:

Initially I expected it to be related to power management, but it is
totally disabled in BIOS and the problem still persists. 

It appears, with my limited knowledge of this area, that the module
tries to free memory that is already free. But why? Is it because the
BIOS and the driver does not agree on the amount of memory availabe
for graphics?

Comment 2 Mikael M. Hansen 2005-02-16 10:14:44 UTC
How is it going with this? It prevent us from rooling out RHEL3WS
clients to our users. 

Comment 3 Xander D Harkness 2005-11-16 13:41:24 UTC
I also experience this.  

There is a work around, in that you can use the vesa module, which does not use the i830 DRI module.

Comment 4 Xander D Harkness 2005-11-16 13:45:14 UTC
This also looks similar to this one here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=157552

Comment 5 Peter Martuccelli 2007-01-23 19:14:15 UTC
Closing out as wontfix in RHEL3, workaround is to use the vesa driver.


Note You need to log in before you can comment on or make changes to this bug.