Bug 145444 - start of daemons freeses when booting with connection to network
start of daemons freeses when booting with connection to network
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-18 11:07 EST by Hantke-Haring
Modified: 2014-03-16 22:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 14:45:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace logfile of blocked "service named stop" (10.83 KB, text/plain)
2005-01-19 03:27 EST, Hantke-Haring
no flags Details
frozen "strace -f service named start" (388.75 KB, text/plain)
2005-01-24 06:17 EST, Hantke-Haring
no flags Details
/var/log/messages of "frozen" service named start (10.18 KB, text/plain)
2005-01-25 05:33 EST, Hantke-Haring
no flags Details

  None (edit)
Description Hantke-Haring 2005-01-18 11:07:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.5)
Gecko/20031007

Description of problem:
-> when booting the system connected to the network, a lot of daemons
like named, dhcpd, mysqld, ... start very slowly or (in worst case)
system freeses.
-> if the system IS NOT connected to the network the start of daemons
at boottime works very well!
-> the same behavior is when system ist running:
e.g. "service named stop" hangs



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. power on system
2. 
3.
    

Actual Results:  -> kernel starts
-> daemons start with status "green"
-> e.g. dhcpd needs 15 sec top start
-> e.g. mysqld freeses - system does not come up

Expected Results:  "normal" boot with all daemons running

Additional info:

I changed network-cables and uses eth1 instead of eth0, but it takes
no effect
Comment 1 Bill Nottingham 2005-01-18 14:14:08 EST
If you strace one of them, where are they hanging? Is your DNS setup
correct?
Comment 2 Hantke-Haring 2005-01-19 03:27:01 EST
Created attachment 109959 [details]
strace logfile of blocked "service named stop"
Comment 3 Hantke-Haring 2005-01-19 03:37:08 EST
DNS setup seems to be correct.

I created a attachment of a strace-log of "service named stop"
This is an exampel - the shutdown of dhcpd "service dhcpd stop"
sometime didn´t work either.
Comment 4 Bill Nottingham 2005-01-19 12:32:01 EST
You need 'strace -f' to actually get the execution of the daemon and
not just the shell script, sorry.
Comment 5 Hantke-Haring 2005-01-24 06:17:44 EST
Created attachment 110114 [details]
frozen "strace -f service named start"

# service named stop -> with exitstatus OK
# strace -f service named start -> this logfile
Comment 6 Bill Nottingham 2005-01-25 00:55:45 EST
What's in the log file from named in this case?

It sounds like your resolver (or similar) config is not correct.
Comment 7 Hantke-Haring 2005-01-25 05:32:07 EST
Hi Bill,

the configuration of the resolver seems to be correct:
192.168.200.245 is the IP of the server we talk about.

# cat /etc/resolv.conf
search sozialwerk-st-georg.de
nameserver 192.168.200.245
nameserver 192.168.10.245

As a new attachment I put the logfile of the "frozen" "service named
start", that I mentioned in comment #5.

to put all "strange things" together:
-> The server boots very well, if the network-cable is *not* connected.
-> The server shows very slow (or frozen) startup of daemons when the
cable is plugged in.
-> Without the line "nameserver 192.168.200.245" in /etc/resolv.conf
the server works very well (this means: it asks the second DNS-server)
-> the named starts without logging any problems in syslog when
starting (see attachment), but it needs several minutes to start

Comment 8 Hantke-Haring 2005-01-25 05:33:38 EST
Created attachment 110188 [details]
/var/log/messages of "frozen" service named start
Comment 9 Bill Nottingham 2005-01-25 10:22:11 EST
Is your first nameserver reachable (via a route or whatever) at the
time the services are starting?
Comment 10 Hantke-Haring 2005-02-02 04:02:43 EST
This server (192.168.200.245) is the first (master) nameserver.
The other one (192.168.10.245) is the second (slave) nameserver.

Between these two machines is a firewall which allows DNS but does not
allow ping.

When replacing "nameserver 192.168.200.245" by "nameserver
192.168.10.245" in /etc/resolv.conf this server seem to work stable.

But: Without connection to network (no cable plugged in) the server
starts without any problems.
Comment 11 Bill Nottingham 2005-02-02 14:45:23 EST
Without connection, it won't bring up the network, and all packages
will get dropped immediately.

I'd probably check the firewall logs to make sure packets aren't
getting dropped; it does seem to be configuration related, not
software related.

Note You need to log in before you can comment on or make changes to this bug.