Bug 1454490 - [abrt] dnfdragora-gui: _on_status_icon_popup_menu(): _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
Summary: [abrt] dnfdragora-gui: _on_status_icon_popup_menu(): _gtk.py:70:_on_status_ic...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:636dff394eb900736b57839dfe6...
: 1515497 1547529 1549997 1550352 1567105 1567549 1572853 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-22 22:36 UTC by Joseph D. Wagner
Modified: 2018-04-30 04:42 UTC (History)
28 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:26:40 UTC


Attachments (Terms of Use)
File: backtrace (531 bytes, text/plain)
2017-05-22 22:36 UTC, Joseph D. Wagner
no flags Details
File: cgroup (289 bytes, text/plain)
2017-05-22 22:36 UTC, Joseph D. Wagner
no flags Details
File: cpuinfo (1012 bytes, text/plain)
2017-05-22 22:36 UTC, Joseph D. Wagner
no flags Details
File: environ (1.34 KB, text/plain)
2017-05-22 22:36 UTC, Joseph D. Wagner
no flags Details
File: mountinfo (3.04 KB, text/plain)
2017-05-22 22:36 UTC, Joseph D. Wagner
no flags Details
File: namespaces (102 bytes, text/plain)
2017-05-22 22:37 UTC, Joseph D. Wagner
no flags Details
File: open_fds (921 bytes, text/plain)
2017-05-22 22:37 UTC, Joseph D. Wagner
no flags Details

Description Joseph D. Wagner 2017-05-22 22:36:49 UTC
Description of problem:
I just clicked on the icon in the system tray.

Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.12.0-0.rc1.git4.1.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
_gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pystray/_gtk.py", line 70, in _on_status_icon_popup_menu
    if self._menu_handle:
AttributeError: 'Icon' object has no attribute '_menu_handle'

Local variables in innermost frame:
activate_time: 124297
button: 3
status_icon: <Gtk.StatusIcon object at 0x7fe8a3bf7af8 (GtkStatusIcon at 0x55df6c94ea60)>
self: <pystray._gtk.Icon object at 0x7fe8a3ebda90>

Comment 1 Joseph D. Wagner 2017-05-22 22:36:55 UTC
Created attachment 1281210 [details]
File: backtrace

Comment 2 Joseph D. Wagner 2017-05-22 22:36:56 UTC
Created attachment 1281211 [details]
File: cgroup

Comment 3 Joseph D. Wagner 2017-05-22 22:36:57 UTC
Created attachment 1281212 [details]
File: cpuinfo

Comment 4 Joseph D. Wagner 2017-05-22 22:36:58 UTC
Created attachment 1281213 [details]
File: environ

Comment 5 Joseph D. Wagner 2017-05-22 22:36:59 UTC
Created attachment 1281214 [details]
File: mountinfo

Comment 6 Joseph D. Wagner 2017-05-22 22:37:00 UTC
Created attachment 1281215 [details]
File: namespaces

Comment 7 Joseph D. Wagner 2017-05-22 22:37:01 UTC
Created attachment 1281216 [details]
File: open_fds

Comment 8 Jan Kurik 2017-08-15 06:16:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 9 Quentin Tayssier 2017-10-13 02:50:53 UTC
Similar problem has been detected:

Start Fedora 27 xfce.
Problem reporting report an error

reporter:       libreport-2.9.2
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.4-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 10 E.Patton 2017-10-14 19:12:01 UTC
*** Bug 1502173 has been marked as a duplicate of this bug. ***

Comment 11 Duncan Grisby 2017-11-16 23:20:06 UTC
Similar problem has been detected:

First login after upgrade to FC27.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.12-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 12 Paul DeStefano 2017-11-20 22:38:37 UTC
*** Bug 1515497 has been marked as a duplicate of this bug. ***

Comment 13 Richard Ruhland 2017-11-21 17:12:07 UTC
*** Bug 1515964 has been marked as a duplicate of this bug. ***

Comment 14 Jay Cravens 2017-11-22 21:07:12 UTC
Similar problem has been detected:

first boot after upgrade from 26 to 27, i right clicked on the new icon, the mostly orange box, and it crashed.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 15 Sethanath 2017-11-23 20:21:40 UTC
*** Bug 1517002 has been marked as a duplicate of this bug. ***

Comment 16 David 2017-11-25 11:10:43 UTC
Similar problem has been detected:

Problem occured during machine start up. Nothing was pressed or touched. 

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.13-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 17 Sethanath 2017-11-26 00:04:39 UTC
*** Bug 1517481 has been marked as a duplicate of this bug. ***

Comment 18 aekryz 2017-11-26 18:49:45 UTC
*** Bug 1517555 has been marked as a duplicate of this bug. ***

Comment 19 buggybuggy 2017-11-27 09:19:59 UTC
*** Bug 1517699 has been marked as a duplicate of this bug. ***

Comment 20 Jay Cravens 2017-11-29 17:29:29 UTC
Similar problem has been detected:

after rebooting from some updates, i right clicked the tray icon and it immediately crashed.

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.15-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 21 Martin Gregorie 2017-12-15 22:03:30 UTC
Similar problem has been detected:

Happened the first time I clicked the dnfdragora icon after upgrading F26 -> F27

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.14.5-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 22 Gunter Halil 2017-12-19 15:45:29 UTC
*** Bug 1527599 has been marked as a duplicate of this bug. ***

Comment 23 ernie95ch 2017-12-29 09:14:48 UTC
*** Bug 1529667 has been marked as a duplicate of this bug. ***

Comment 24 Fedora Update System 2017-12-29 23:20:20 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 25 Fedora Update System 2017-12-29 23:26:16 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 26 Fedora Update System 2017-12-30 19:53:11 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 27 Fedora Update System 2017-12-30 20:39:00 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 28 Fedora Update System 2017-12-31 21:26:40 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2018-01-01 22:10:23 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 Vitaliy 2018-01-12 20:55:09 UTC
Similar problem has been detected:

When i login to the system I take message about mistake

reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 /bin/dnfdragora-updater
crash_function: _on_status_icon_popup_menu
exception_type: AttributeError
executable:     /bin/dnfdragora-updater
kernel:         4.14.8-300.fc27.x86_64
package:        dnfdragora-gui-1.0.1-6.git20170505.2a3b056.fc27
reason:         _gtk.py:70:_on_status_icon_popup_menu:AttributeError: 'Icon' object has no attribute '_menu_handle'
runlevel:       N 5
type:           Python3
uid:            1000

Comment 31 chris goodwin 2018-02-21 13:44:12 UTC
*** Bug 1547529 has been marked as a duplicate of this bug. ***

Comment 32 chiguy1256 2018-02-28 09:20:58 UTC
*** Bug 1549997 has been marked as a duplicate of this bug. ***

Comment 33 Muhammad Fitrah 2018-03-01 04:22:32 UTC
*** Bug 1550352 has been marked as a duplicate of this bug. ***

Comment 34 Breno Rangel Silveira 2018-04-13 12:28:40 UTC
*** Bug 1567105 has been marked as a duplicate of this bug. ***

Comment 35 Ketil Thorsen 2018-04-14 21:04:17 UTC
*** Bug 1567549 has been marked as a duplicate of this bug. ***

Comment 36 sebastian 2018-04-28 06:58:56 UTC
*** Bug 1572853 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.