Bug 1454614 - LVM uninstallable in Rawhide
Summary: LVM uninstallable in Rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: LVM and device-mapper development team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2017-05-23 07:47 UTC by Richard W.M. Jones
Modified: 2017-05-23 09:34 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-23 09:32:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard W.M. Jones 2017-05-23 07:47:17 UTC
Description of problem:

DEBUG util.py:439:  Error: nothing provides device-mapper-persistent-data >= 0.7.0-0.1.rc6 needed by lvm2-2.02.171-2.fc27.x86_64.
DEBUG util.py:439:  nothing provides device-mapper-persistent-data >= 0.7.0-0.1.rc6 needed by lvm2-2.02.171-2.fc27.x86_64

Version-Release number of selected component (if applicable):

See above.

How reproducible:

100%

Steps to Reproduce:
1. Try to install lvm2.

Comment 1 Marian Csontos 2017-05-23 08:05:24 UTC
It is provided for both Server and Workstation.

Is this a spin or other "product"? Cloud/container/atomic-whatever?

What repos do you have configured?

Comment 2 Richard W.M. Jones 2017-05-23 08:19:03 UTC
This is in Rawhide, there are no spins.

See the failing build:

https://koji.fedoraproject.org/koji/taskinfo?taskID=19701375

Comment 3 Alasdair Kergon 2017-05-23 08:28:10 UTC
device-mapper-persistent-data-0.7.0-0.1.rc6.fc27
https://koji.fedoraproject.org/koji/buildinfo?buildID=873112

Comment 4 Marian Csontos 2017-05-23 08:32:33 UTC
Oh, looks like mass rebuilt build wrong branches. See releng tasks.

https://koji.fedoraproject.org/koji/packageinfo?packageID=13011

Let's check if some other packages are affected...

Comment 5 Marian Csontos 2017-05-23 09:32:08 UTC
Caused by mass rebuild: https://pagure.io/releng/issue/6807

I submitted new builds to fix it. It will take a while to propagate to repos though.

The newly built package is here: https://koji.fedoraproject.org/koji/buildinfo?buildID=896547

Comment 6 Richard W.M. Jones 2017-05-23 09:34:06 UTC
It seems to be fixed by your rebuild of device-mapper-persistent-data
just now, thanks.


Note You need to log in before you can comment on or make changes to this bug.