Bug 1454942 - rgw_file: remove unlinked assertions
Summary: rgw_file: remove unlinked assertions
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: All
OS: All
unspecified
low
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Keywords: CodeChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-23 20:19 UTC by Matt Benjamin (redhat)
Modified: 2017-07-30 16:00 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-19 13:33:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Ceph Project Bug Tracker 20047 None None None 2017-05-23 20:19 UTC

Description Matt Benjamin (redhat) 2017-05-23 20:19:05 UTC
Description of problem:
The rgw_file/RGW nfs unlink() call path contains a live assert() that successfully unlinked objects cannot be found in a subsequent lookup.  This assert could trigger in a false positive in a multi-gateway environment racing to create/unlink objects.

Comment 2 Matt Benjamin (redhat) 2017-05-23 23:06:19 UTC
Steps to Reproduce
No requirement to reproduce.  The change removes logic to assert() in a condition that could be, but never has in development, been reproduced in a multi-gateway deployment scenario where overlapping ranges of files and directories were being simultaneously created and deleted without coordination.

Actual Results
As above.

Expected Results
As above.

Comment 8 Matt Benjamin (redhat) 2017-06-05 11:36:07 UTC
(the issue was resolved, NEEDINFO should have been cleared)

Comment 10 errata-xmlrpc 2017-06-19 13:33:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.