Bug 145495 - RFE: Make text in error dialogs selectable
RFE: Make text in error dialogs selectable
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-18 17:49 EST by Dave Malcolm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 18:46:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 92167 None None None Never

  None (edit)
Description Dave Malcolm 2005-01-18 17:49:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
I'm experiencing various errors and problem with Eclipse in rawhide,
and it would be nice to be able to copy&paste text from the error
dialogs into IRC and into Bugzilla.

Unfortunately, the text in the error dialogs I've seen so far isn't
selectable which makes reporting this data a major pain.

Version-Release number of selected component (if applicable):
eclipse-gtk2-3.1-0.M4.19

How reproducible:
Always

Steps to Reproduce:
1. get eclipse to malfunction
2. see error dialog containing text which might be informative in a
bug report
3. try to highlight the text
    

Actual Results:  Text should be selectable, so I can paste it into
bugzilla

Expected Results:  Text is not selectable

Additional info:

Marking as High severity since it makes it much more difficult to
report all the other bugs that I'm seeing (alas).

Hopefully just a case of calling gtk_label_set_selectable (or the
equivalent) in the appropriate place.
Comment 1 Phil Muldoon 2005-04-05 15:45:22 EDT
This would requite modification of the JFACE/SWT text and possibly dialog
functions, so it would require a change from the upstream source. It's unlikely
this will happen soon, due to the time required in fixing native bugs that arise
out of native compilation.

FWIW all errors and stack traces should also go to {yourworkspace}/.metadata/.log
Comment 2 Ben Konrath 2005-04-05 16:27:41 EDT
Perhaps a bug about this should be file upstream.
Comment 3 Phil Muldoon 2005-04-05 16:32:54 EDT
Agreed.
Comment 4 Ben Konrath 2005-04-20 18:46:54 EDT
Bug filed upstream, closing.

Note You need to log in before you can comment on or make changes to this bug.