Bug 145499 - openmotif version number breaks Oracle 10g installer
openmotif version number breaks Oracle 10g installer
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openmotif (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-18 18:20 EST by Richard Lloyd
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 08:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Lloyd 2005-01-18 18:20:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The latest update to the openmotif package now blocks the Oracle 10g
installer from correctly detecting the openmotif version number and
hence, rather embarrassingly, for Red Hat and Oracle, what being
partners and all and being "certified" to work with each other, if you
use the latest Oracle 10g (10.1.0.3.0) installer on Linux x86 and you
are running RHEL 3 with all the latest RPMs (including pre-requisites
for the Oracle installer) installed via "up2date -u", you *cannot*
install Oracle 10g on RHEL 3. Whoops! "Unbreakable Oracle"? I can't
even install it to break it :-)

Version-Release number of selected component (if applicable):
openmotif-2.2.3-4.RHEL3.4

How reproducible:
Always

Steps to Reproduce:
1. "up2date -u openmotif" to install the 2.2.3-4.RHEL3.4 version of
openmotif if you don't already have it.
2. Follow the Oracle 10g installer instructions at 
http://www.oracle.com/technology/pub/articles/smiley_10gdb_install.html
(but use the updated openmotif version)
3. Execute ./runInstaller as the instructions say.


Actual Results:  Watch runInstaller barf, complaining that you don't
have the required openmotif package installed !
    

Expected Results:  runInstaller should detect the version of openmotif
correctly and continue on to the actual installation.

Additional info:

OK, this isn't necessarily entirely Red Hat's fault, but I don't know
if Oracle have a public reporting tool like Bugzilla and it *was* the
RH openmotif update that broke the Oracle 10g installer, so....someone
needs to check the runInstaller version parsing algorithm and either
"massage" openmotif's version to get past the Oracle installer checks
or, failing that, report the issue to Oracle (it's probably someone
from Red Hat who should do that I guess)....

The workaround is, of course, to go back to your RHEL 3 CDs and
install an earlier openmotif RPM that doesn't have that "wacky" new
version number of 2.2.3-4.RHEL3.4 that upsets the obviously naff
version detection code in the Oracle 10g installer. I just used
openmotif 2.2.2-16 from the (quite old now) original RHEL 3 CDs and
that let the install sail through.

One note - if you intend to re-install Oracle 10g at a later date, you
may want to edit /etc/sysconfig/rhn/up2date and add openmotif* to your
list of exclusions for packages to be updated:

pkgSkipList=kernel*;openmotif*;

If you don't do this, "up2date -u" will just put back the "broken
version number" openmotif package and you'll be back to square one
again...
Comment 4 Ken Hollingsworth 2005-02-18 01:41:16 EST
I'm also looking forward to a solution to this bug.  I'm new to
Bugzilla, and I'm adding myself to the cc: list in hopes of receiving
prompt notification when a fix is available.
Comment 6 Nils Philippsen 2005-05-06 04:45:30 EDT
FYI, with SAP and Oracle 9i we have run into similar problems, in this instance
regarding the operating system version (the runInstaller for 9.2.0.5 complained
about that it doesn't want to run on RHEL4). We worked around that problem by
using the "-ignoreSysPrereqs" switch for runInstaller, perhaps this works here
as well.
Comment 7 Thomas Woerner 2005-05-11 08:45:23 EDT
This is no openmotif problem. Closing as "NOT A BUG".

Note You need to log in before you can comment on or make changes to this bug.