Bug 1455078 - Update python-idna to version 2.5
Summary: Update python-idna to version 2.5
Keywords:
Status: CLOSED DUPLICATE of bug 1425154
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-idna
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Nathaniel McCallum
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-24 08:44 UTC by Alfredo Moralejo
Modified: 2017-08-10 14:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1455346 (view as bug list)
Environment:
Last Closed: 2017-08-10 14:07:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alfredo Moralejo 2017-05-24 08:44:24 UTC
Description of problem:

Currently python-idna-2.0 is shipped in RHEL 7.3. This version consumes around 25MB of memory only to load:

>>> import resource
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
5052
>>> import idna
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
31344
>>> 

Some memory optimizations have been applied upstream from release 2.0 until latest one, 2.5 leading to a huge improvement:

>>> import resource
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
5048
>>> import idna
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
5888
>>> 

Reviewing the commits from v2.0..v2.5, there have been no changes in the public methods of the library, so it seems to be fully compatible with version 2.0, so i'd say it should be safe to update it.


OpenStack services using eventlet are using idna via import from python-dns, which is leading to increase memory usage.

I'm setting version 7.4, however i'm not sure if this request arrives on time to be included in 7.4 or needs to be moved to 7.5.

Comment 2 Christian Heimes 2017-08-10 14:00:17 UTC
This is a duplicate of #1425154.

There is no need to update python-idna to address the issue. RHEL 7.4 comes with python-idna-2.4-1.el7. Memory consumption of python-idna was addressed in upstream releases 2.1 and 2.3, https://github.com/kjd/idna/blob/master/HISTORY.rst . I requested errata https://access.redhat.com/errata/RHBA-2017:1996 for the same reason.

Comment 3 Christian Heimes 2017-08-10 14:07:26 UTC
I'm closing this BZ as duplicate. Please feel free to re-open the BZ if you a fix from python-idna 2.5.

*** This bug has been marked as a duplicate of bug 1425154 ***


Note You need to log in before you can comment on or make changes to this bug.