Bug 145510 - Won't boot Dell 8400 kernel-2.6.10 updates
Won't boot Dell 8400 kernel-2.6.10 updates
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 00:59 EST by sjberryman
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:20:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sjberryman 2005-01-19 00:59:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 
7.54  [en]

Description of problem:
No kernel-2.6.10 update releases will boot on my Dell 8400 PC.

kernel-2.6.9-1.11smp and previous smp and non-smp kernels boot and 
work OK.

Stops at the console line "Configuring Kernel Parameters" and needs a 
power cycle to reboot thereafter.

Booting in non-gui mode. Doesn't get far enough to give any other 
debugging info.

Tried kernel-2.6.10-1.9_fc2SMP, kernel-2.6.10-1.8_fc2SMP, kernel-2.6.
10-1.9_fc2, all with the same result.

The machine is a pentium 4 with a single processor and a SATA hard 
drive.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.8_FC2smp, 2.6.10-1.9_FC2smp, 2.6.10-1.9_FC2

How reproducible:
Always

Steps to Reproduce:
1.Install 2.6.10-? kernel
2.Reboot
3.Select 2.6.10-? kernel at grub prompt.
    

Actual Results:  Stops at the statement

Configuring Kernel Parameters.

Hangs indefinately until power cycle

Expected Results:  Successfull boot.

Additional info:
Comment 1 Jan D. 2005-01-24 07:03:30 EST
I got the same problem on a Dell SX280.  It is this command in
rc.sysinit that hangs:
hwclock --utc --hctosys

This worked fine in previous (2.6.9) kernels.
Comment 2 sjberryman 2005-01-24 19:41:31 EST
Thanks Jan D 
I commented out the hwclock command in rc.sysinit and my Dell 
Dimension 8400 now boots ok. 
Comment 3 Jan D. 2005-01-26 06:41:10 EST
The workaround mentioned in bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144894 also
works, i.e.:

hwclock --directisa ...

That bug is for Fedora Core 3, but it is the same problem as for this bug.
Comment 4 Dave Jones 2005-04-16 00:20:28 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.