Bug 1455181 - Version 0.2.4-6.rc1.fc25 fails to register ypbind
Summary: Version 0.2.4-6.rc1.fc25 fails to register ypbind
Keywords:
Status: CLOSED DUPLICATE of bug 1450765
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-24 12:23 UTC by Thomas Clark
Modified: 2017-06-01 17:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-01 17:19:40 UTC


Attachments (Terms of Use)

Description Thomas Clark 2017-05-24 12:23:16 UTC
Description of problem:

Upgrading to version 0.2.4-6.rc1.fc25 causes failure to register any programs that try to register after portmapper.  I am using ypbind, rstatd and rusersd.  This version of rpcbind registers portmapper, but fails to register anything afterward.

Version-Release number of selected component (if applicable):
0.2.4-6.rc1.fc25

How reproducible:
Reproducible 100%

Steps to Reproduce:
1.Upgrade to 0.2.4-6.rc1.fc25
2.Reboot
3.

Actual results:
100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper


Expected results:
100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100001    3   udp    692  rstatd
    100002    3   udp    691  rusersd
    100001    2   udp    692  rstatd
    100002    2   udp    691  rusersd
    100001    1   udp    692  rstatd
    100007    2   udp    610  ypbind
    100007    1   udp    610  ypbind
    100007    2   tcp    613  ypbind
    100007    1   tcp    613  ypbind
    100024    1   udp  40643  status
    100024    1   tcp  53453  status


Additional info:
Downgrading to 0.2.3-11.rc1.fc25 fixes the issue.

Comment 1 Thomas Clark 2017-05-24 15:07:30 UTC
Found these relevant log entries:
May 23 20:54:26 amelia audit: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=rpcbind comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
May 23 20:54:26 amelia ypbind-post-waitbind: rpcinfo: can't contact portmapper: RPC: Unable to receive; errno = Connection reset by peer
May 23 20:54:26 amelia systemd: rpcbind.service: Main process exited, code=killed, status=6/ABRT

...
May 23 20:55:12 amelia ypbind: Binding took 46 seconds
May 23 20:55:12 amelia ypbind: NIS domain: clark, ypbind not registered with rpcbind.

Comment 2 Robert Van Voorhees 2017-05-27 18:25:40 UTC
Not sure if related, but on a fresh install of Fedora 25 with rpcbind-0.2.4-6.rc1.fc25.x86_64, I am receiving the following when I attempt to start rpcbind:

➜  ~ systemctl status rpcbind.service
● rpcbind.service - RPC Bind
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit-hit) since Sat 2017-05-27 14:04:28 EDT; 16s ago
     Docs: man:rpcbind(8)
  Process: 7351 ExecStart=/usr/bin/rpcbind $RPCBIND_OPTIONS -w -f (code=exited, status=1/FAILURE)
 Main PID: 7351 (code=exited, status=1/FAILURE)

May 27 14:04:28 server.localhost systemd[1]: Starting RPC Bind...
May 27 14:04:28 server.localhost rpcbind[7351]: sh: /usr/bin/systemd-tmpfiles: Permission denied
May 27 14:04:28 server.localhost rpcbind[7351]: rpcbind: /run/rpcbind/rpcbind.lock: No such file or directory
May 27 14:04:28 server.localhost systemd[1]: rpcbind.service: Main process exited, code=exited, status=1/FAILURE
May 27 14:04:28 server.localhost systemd[1]: Failed to start RPC Bind.
May 27 14:04:28 server.localhost systemd[1]: rpcbind.service: Unit entered failed state.
May 27 14:04:28 server.localhost systemd[1]: rpcbind.service: Failed with result 'exit-code'.
May 27 14:04:28 server.localhost systemd[1]: rpcbind.service: Start request repeated too quickly.
May 27 14:04:28 server.localhost systemd[1]: Failed to start RPC Bind.
May 27 14:04:28 server.localhost systemd[1]: rpcbind.service: Failed with result 'start-limit-hit'.

Downgrading to rpcbind-0.2.3-11.rc1.fc25.x86_64 fixes the issue.

Comment 3 Steve Dickson 2017-06-01 17:19:40 UTC

*** This bug has been marked as a duplicate of bug 1450765 ***


Note You need to log in before you can comment on or make changes to this bug.