Bug 14553 - Subtile bug causing stacktrace
Subtile bug causing stacktrace
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Winston rc1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-24 16:19 EDT by Hans de Goede
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-31 16:57:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stacktrace (3.02 KB, text/plain)
2000-07-24 16:20 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2000-07-24 16:19:37 EDT
-low memory machine (boot with linux mem=16M)
-select workstation
-manual partition
-yes enable swap
-hmm, disks are to small anyways I want a custom install
-back
-select no on enable swap (see bug 14551) 
-note going forward now again, selecting yes again for enable swap
 (so swap would be enabled twice) works, and there is no message
 about formatting swap so I guess this stepped is skipped the second time,
 but then why still show the box?
-go back all the way to the install type selection screen
-select custom install
-use diskdruid
-select yes for enable swap, now really tries to enable it twice -> BOOM

Also see the soon to be attached stacktrace.
Comment 1 Hans de Goede 2000-07-24 16:20:03 EDT
Created attachment 1492 [details]
stacktrace
Comment 2 Glen Foster 2000-07-30 15:47:31 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 3 Michael Fulbright 2000-07-31 16:57:16 EDT
This should work if you get your space setup properly before you get to the 'not
enough space screen'.

Trying to enable/disable swap many times is going to break.

Comment 4 Hans de Goede 2000-08-05 14:58:30 EDT
Why?

I don't see what is the problem, granted disabling swap on back is ugly, so keep
a few global vars (one per partition) if swap is on on that partition, maybe
this info is even somewhere in proc. If swap is in use and someone decides to
change the partition table the sync will fail, this should bring up a you need
to reboot screen, I guess this is already there, otherwise I forsee big problems
with hd installs.
Comment 5 Hans de Goede 2000-08-11 14:36:41 EDT
Please note that I did not go al the way up to the not enough free diskspace
message, immediatly after the swap is needed now screen I went back, since I
changed my mind and wanted a custom install so the problem track is:

-Standard workstation install
-partition
-low on memory need to enable swap now
-hmm I changed my mind go back and select custom
-partitiom
-low on memory message
-BOOM

So the problem is that the swap space status is remembered seperate for an
custom and a workstation install, going back and forward 100 times in just
install method works fine.

Note You need to log in before you can comment on or make changes to this bug.