Bug 145538 - D-Link DGE-530T not detected (sk98lin)
D-Link DGE-530T not detected (sk98lin)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hwdata (Show other bugs)
4.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks: 137160
  Show dependency treegraph
 
Reported: 2005-01-19 10:08 EST by Pascal de Bruijn
Modified: 2014-03-16 22:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-120
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 09:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pascal de Bruijn 2005-01-19 10:08:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I've recently purchased a D-Link DGE-530T Gigabit Copper Ethernet
adapter. The card is based on the newer Marvell Yukon chip:
http://www.marvell.com/products/pcconn/yukon/88E8003.jsp

It used the sk98lin driver:
When I modprobe sk98lin I get this"

eth0: DGE-530T Gigabit Ethernet Adapter
      PrefPort:A  RlmtMode:Check Link State
Then I can ifconfig eth0, and everything works fine...

MY PROBLEM: kudzu won't autodetect the card.

lspci -vv for the DGE-530T:
------------------------------------------------------------------------
00:0a.0 Ethernet controller: D-Link System Inc Gigabit Ethernet
Adapter (rev 11)
	Subsystem: D-Link System Inc DGE-530T Gigabit Ethernet Adapter
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 32 (5750ns min, 7750ns max), Cache Line Size 08
	Interrupt: pin A routed to IRQ 185
	Region 0: Memory at e3800000 (32-bit, non-prefetchable) [size=16K]
	Region 1: I/O ports at b800 [size=256]
	Capabilities: [48] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=1 PME-
	Capabilities: [50] Vital Product Data
------------------------------------------------------------------------

I also noticed that the driver is quite outdated, a newer 7.09 is
available here:
http://www.syskonnect.com/syskonnect/support/driver/htm/sk9e21_lin.htm
It has some nice new features like NAPI.

Version-Release number of selected component (if applicable):
kernel 2.6.9-1.675 SMP

How reproducible:
Always

Steps to Reproduce:
1. Install the card.
2. Boot the machine
    

Actual Results:  The card isn't autodetected.

Expected Results:  The card should be autodetected by kudzu.

Additional info:
Comment 3 Bill Nottingham 2005-01-19 16:07:43 EST
Added in CVS. 
Comment 4 Bill Nottingham 2005-03-01 12:57:22 EST
In 0.146.2.EL-1.
Comment 5 Pascal de Bruijn 2005-03-07 14:02:39 EST
I'm running 2.6.9-5.0.3.EL now, the card still isn't detected.

Also any chance, of seeing the sk98lin card officially supported? with
newer driver versions?

If you need any more information please lett me know...
Comment 6 Bill Nottingham 2005-03-07 14:44:30 EST
If you manually load the driver does it work? The fix is in
hwdata-0.146.2.EL-1 to manually set a mapping for it, since the driver
doesn't export tables of what cards it supports.
Comment 7 Pascal de Bruijn 2005-03-07 16:00:41 EST
When I manually load it, it works...

Also, If I'm not mistaken, a while back, I patched my kernel with the
newer sk98lin driver, and I think kudzu detected it back then...

Anyway, like I said before, I can really recommend the newer driver...

Thanks for the assistance,
Pascal de Bruijn
Comment 8 Tim Powers 2005-06-09 09:01:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-120.html

Note You need to log in before you can comment on or make changes to this bug.