Bug 145542 - Incorrect @INC in perl 5.8.6 ?
Incorrect @INC in perl 5.8.6 ?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 10:41 EST by Marco Pesenti Gritti
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 22:15:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Pesenti Gritti 2005-01-19 10:41:00 EST
I dont know much about perl but it seem that @INC should contain also
the 5.8.5 directory.

This cause the perl-XML-Parser package to not work correctly and so
it's not possible to build most GNOME packages on devel anymore.

perl -e "require XML::Parser"
Can't locate XML/Parser.pm in @INC (@INC contains:
/usr/lib/perl5/5.8.6/ia64-linux-thread-multi /usr/lib/perl5/5.8.6
/usr/lib/perl5/site_perl/5.8.6/ia64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.4/ia64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3/ia64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/ia64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/ia64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/ia64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.4
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.6/ia64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.4/ia64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3/ia64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/ia64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/ia64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/ia64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.4
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl .) at -e line 1.
Comment 1 Marco Pesenti Gritti 2005-01-19 10:44:49 EST
I tested this on ia64 and s390, I dont know if it's architecture
dependent.
Comment 2 Marco Pesenti Gritti 2005-01-19 10:50:13 EST
It's actually reproducable on i386 too.
Comment 3 Reuben Farrelly 2005-01-19 15:59:19 EST
It'll be breaking all platforms.

Given that virtually all perl RPM packages are now broken since the upgrade
(core modules bundled with perl-5.8.6 work ok), perhaps it would be a good time
to systematically go through and update all the perl modules in the distribution
(most are tiny though), and rebuild against the current 5.8.6 binary.
Comment 4 Chip Turner 2005-01-20 22:15:46 EST
this should now be fixed in perl 5.8.6-2 and later, which should be in rawhide

Note You need to log in before you can comment on or make changes to this bug.