Bug 1455501 - Create/Update user with e-mail address containing extra consecutive dots is allowed
Summary: Create/Update user with e-mail address containing extra consecutive dots is a...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.3.0
Hardware: x86_64
OS: Linux
low
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1457261 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-25 11:02 UTC by Djebran Lezzoum
Modified: 2017-07-10 11:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-10 11:48:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 19696 0 None None None 2017-05-29 08:20:50 UTC

Description Djebran Lezzoum 2017-05-25 11:02:23 UTC
Description of problem:
Create/Update user with e-mail address containing extra consecutive dots is allowed

Version-Release number of selected component (if applicable):
* candlepin-2.0.30-1.el7.noarch
* candlepin-selinux-2.0.30-1.el7.noarch
* foreman-1.15.0-0.1.RC2.el7sat.noarch
* foreman-compute-1.15.0-0.1.RC2.el7sat.noarch
* foreman-debug-1.15.0-0.1.RC2.el7sat.noarch
* foreman-ec2-1.15.0-0.1.RC2.el7sat.noarch
* foreman-gce-1.15.0-0.1.RC2.el7sat.noarch
* foreman-installer-1.15.0-0.develop.201703100324gitb570b53.el7sat.noarch
* foreman-installer-katello-3.5.0-1.nightly.201703312206git730de81.el7sat.noarch
* foreman-libvirt-1.15.0-0.1.RC2.el7sat.noarch
* foreman-openstack-1.15.0-0.1.RC2.el7sat.noarch
* foreman-ovirt-1.15.0-0.1.RC2.el7sat.noarch
* foreman-postgresql-1.15.0-0.1.RC2.el7sat.noarch
* foreman-proxy-1.15.0-0.1.RC2.el7sat.noarch
* foreman-rackspace-1.15.0-0.1.RC2.el7sat.noarch
* foreman-selinux-1.15.0-0.1.RC2.el7sat.noarch
* foreman-vmware-1.15.0-0.1.RC2.el7sat.noarch
* katello-3.4.0-1.rc2.el7sat.noarch
* katello-ca-consumer-sat-r220-02.lab.eng.rdu2.redhat.com-1.0-1.noarch
* katello-certs-tools-2.4.0-1.el7sat.noarch
* katello-client-bootstrap-1.3.0-1.el7sat.noarch
* katello-common-3.4.0-1.rc2.el7sat.noarch
* katello-debug-3.4.0-1.rc2.el7sat.noarch
* katello-default-ca-1.0-1.noarch
* katello-installer-base-3.5.0-1.nightly.201703312206git730de81.el7sat.noarch
* katello-selinux-3.0.2-1.el7sat.noarch
* katello-server-ca-1.0-1.noarch
* katello-service-3.4.0-1.rc2.el7sat.noarch
* openldap-2.4.40-13.el7.x86_64
* pulp-client-1.0-1.noarch
* pulp-docker-plugins-2.3.0-1.git.0.02c948c.el7sat.noarch
* pulp-katello-1.0.2-1.el7sat.noarch
* pulp-puppet-plugins-2.12.1-1.git.0.1aeb10f.el7sat.noarch
* pulp-puppet-tools-2.12.1-1.git.0.1aeb10f.el7sat.noarch
* pulp-rpm-plugins-2.12.1-1.el7sat.noarch
* pulp-selinux-2.12.1-1.git.0.b41b7ba.el7sat.noarch
* pulp-server-2.12.1-1.git.0.b41b7ba.el7sat.noarch
* python-ldap-2.4.15-2.el7.x86_64
* tfm-rubygem-ldap_fluff-0.4.6-1.el7sat.noarch
* tfm-rubygem-net-ldap-0.15.0-1.el7sat.noarch


How reproducible:
Always

Steps to Reproduce:
1.hammer user create --firstname="fSqPgRGpBY" --lastname="ALnULfJpKo" --mail="dot..dot@example.com" --login="user" --password="password" --auth-source-id="1"
2.
3.

Actual results:
The user is created
Message,Id
User [user] created,373

Expected results:
[ERROR 2017-05-25 05:47:12 API] 422 Unprocessable Entity
[ERROR 2017-05-25 05:47:12 Exception] Email address is invalid
Could not create the user:
  Email address is invalid

Additional info:
The current behavior is reproducible in UI also, and also allow to update the user data with this invalid e-mails
invalid e-mails examples that are invalid and allow the user to be created/updated:
email@example..c
dot..dot@example.com
dot...dot@example....com

Comment 2 Marek Hulan 2017-05-29 08:20:48 UTC
Created redmine issue http://projects.theforeman.org/issues/19696 from this bug

Comment 3 Marek Hulan 2017-05-29 08:22:56 UTC
Thanks for the report, I'm lowering the priority, I don't think has a big impact and I don't expect it to be fixed soon.

Comment 4 Stanislav Tkachenko 2017-06-01 08:19:37 UTC
*** Bug 1457261 has been marked as a duplicate of this bug. ***

Comment 5 Marek Hulan 2017-07-10 11:48:59 UTC
Closing since this was rejected upstream, please see https://github.com/theforeman/foreman/pull/4587#pullrequestreview-45746763 for more information why.


Note You need to log in before you can comment on or make changes to this bug.