Bug 1455798 - firefox does not start after update
Summary: firefox does not start after update
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: Desktop QE
Lucie Maňásková
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-26 07:39 UTC by Oliver Haessler
Modified: 2019-08-23 05:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Firefox does not start after update After the upgrade to firefox-52.1.2-.el7.x86_64 and further, the browser does not start in some cases. This is due to the _nspr_ and _nss_ packages not being updated from the Red Hat Enterprise Linux 7.4 batch. To work around this problem, update the _nspr_ and _nss_ packages from Red Hat Enterprise 7.4 release. Another possible workaround is to downgrade Firefox, but this option is not recommended. As a result, it is possible to start the Firefox web browser again.
Clone Of:
Environment:
Last Closed: 2019-08-23 05:59:09 UTC


Attachments (Terms of Use)

Description Oliver Haessler 2017-05-26 07:39:27 UTC
Description of problem:
After upgrading to firefox-52.1.2-1.el7.x86_64 the browser is not starting anymore.

Version-Release number of selected component (if applicable):
firefox-52.1.2-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. update to firefox-52.1.2-1.el7.x86_64
2. start firefox

Actual results:
[ohaessle@ohaessle ~]$ rpm -qa | grep ^firefox
firefox-52.1.2-1.el7.x86_64
[ohaessle@ohaessle ~]$ firefox
XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so:
/lib64/libnss3.so: version `NSS_3.30' not found (required by /usr/lib64/firefox/libxul.so)


Expected results:
Firefox starts

Comment 2 Tomas Pelka 2017-05-26 09:02:21 UTC
Hmm 

$ rpm -q firefox nss                  
firefox-52.1.2-1.el7.x86_64
nss-3.28.4-8.el7.x86_64


$ rpm -q --requires firefox | grep nss
nss >= 3.28.2
libnss3.so()(64bit)
libnssutil3.so()(64bit)

And I can start FF

Comment 3 hannuk 2017-08-02 10:02:35 UTC
This bug is still alive. Exact same symptoms.

firefox-52.2.0-2.el7.x86_64
nss-3.28.4-1.2.el7_3.x86_64

Error:

XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so:
/lib64/libnss3.so: version `NSS_3.30' not found (required by /usr/lib64/firefox/libxul.so)
Couldn't load XPCOM.

Comment 4 Martin Stransky 2017-08-03 12:10:16 UTC
Hm, interesing. Can you please attach output of ld.so (see man ld.so), run  "LD_DEBUG=all firefox > output.txt 2>&1" from console and attach the output file here. Thanks.

Comment 5 Martin Stransky 2017-08-03 12:12:00 UTC
Anyway, you should be able to find out what's wrong from the ld.so output - ld.so is a dynamic linker which loads libraries when firefox starts.

Comment 6 Shatadru Bandyopadhyay 2017-08-04 09:17:22 UTC
hitting this with below version
~~~
# rpm -q firefox
firefox-52.2.0-2.el7.x86_64
[root@instack ~]# rpm -q nss
nss-3.28.4-1.2.el7_3.x86_64
~~~

After downgrading it gets fixed :
~~~
# rpm -q firefox
firefox-52.2.0-1.el7_3.x86_64
[root@instack ~]# rpm -q nss
nss-3.28.4-1.2.el7_3.x86_64
~~~

Error :
~~~
Aug 04 04:37:45 instack.localdomain firefox.desktop[6531]: XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so:
Aug 04 04:37:45 instack.localdomain firefox.desktop[6531]: /lib64/libnss3.so: version `NSS_3.30' not found (required by /usr/lib64/firefo
~~~

# ldd /usr/lib64/firefox/libxul.so
/usr/lib64/firefox/libxul.so: /lib64/libnss3.so: version `NSS_3.30' not found (required by /usr/lib64/firefox/libxul.so)
	linux-vdso.so.1 =>  (0x00007ffff45d7000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f4470ce8000)
....

Comment 8 Oliver Haessler 2017-08-07 13:39:56 UTC
and seeing the same error now with firefox-52.3.0-2.el7_4.x86_64 on RHEL 7.3 as well..

Comment 10 Martin Stransky 2017-08-09 08:45:23 UTC
can you please run on terminal:

objdump -T /usr/lib64/firefox/libxul.so | grep NSS_3.30

and paste the output here.

also otput of "rpm -qi firefox" command.

Comment 11 Oliver Haessler 2017-08-09 09:17:55 UTC
sure:

[root@dhcp-64-78 ~]# objdump -T /usr/lib64/firefox/libxul.so | grep NSS_3.30
0000000000000000      DF *UND*	0000000000000000  NSS_3.30    PK11_HasAttributeSet

*****

[root@dhcp-64-78 ~]# rpm -qi firefox
Name        : firefox
Version     : 52.3.0
Release     : 2.el7_4
Architecture: x86_64
Install Date: Wed 09 Aug 2017 10:59:18 AM CEST
Group       : Applications/Internet
Size        : 156689065
License     : MPLv1.1 or GPLv2+ or LGPLv2+
Signature   : (none)
Source RPM  : firefox-52.3.0-2.el7_4.src.rpm
Build Date  : Thu 03 Aug 2017 09:57:05 AM CEST
Build Host  : x86-041.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://www.mozilla.org/projects/firefox/
Summary     : Mozilla Firefox Web browser
Description :
Mozilla Firefox is an open-source web browser, designed for standards
compliance, performance and portability.

Comment 12 Shatadru Bandyopadhyay 2017-08-09 09:26:47 UTC
# rpm -q nss firefox
nss-3.28.4-1.2.el7_3.x86_64
firefox-52.2.0-2.el7.x86_64


# rpm -q --requires firefox|grep -i nss
nss >= 3.28.4
libnss3.so()(64bit)
libnssutil3.so()(64bit)


Note : after a "#yum update nss"  it works fine.
~~~
# rpm -q nss firefox
nss-3.28.4-11.el7_4.x86_64
firefox-52.2.0-2.el7.x86_64
~~~

Else older version of firefox works with old nss
~~~
# rpm -q firefox nss
firefox-52.2.0-1.el7_3.x86_64
nss-3.28.4-1.2.el7_3.x86_64
~~~


Below is the update summary :
~~~
Packages Altered:
    Updated     nss-3.28.4-1.2.el7_3.x86_64         @rhel-7-server-rpms
    Update          3.28.4-11.el7_4.x86_64          @rhel-7-server-rpms
    Dep-Install nss-pem-1.0.3-4.el7.x86_64          @rhel-7-server-rpms
    Updated     nss-sysinit-3.28.4-1.2.el7_3.x86_64 @rhel-7-server-rpms
    Update                  3.28.4-11.el7_4.x86_64  @rhel-7-server-rpms
    Updated     nss-tools-3.28.4-1.2.el7_3.x86_64   @rhel-7-server-rpms
    Update                3.28.4-11.el7_4.x86_64    @rhel-7-server-rpms
    Updated     nss-util-3.28.4-1.0.el7_3.x86_64    @rhel-7-server-rpms
    Update               3.28.4-3.el7.x86_64        @rhel-7-server-rpms

~~~

May be we can update the firefox spec file which would pull the latest nss which is required for latest firefox.

nss >= 3.28.4-11

--Shatadru

Comment 13 Martin Stransky 2017-08-09 10:17:37 UTC
Yes, the problem is that nss from RHEL 7.4 has backported the https://bugzilla.mozilla.org/show_bug.cgi?id=1345083 fix and a new symbol PK11_HasAttributeSet is provided here. 

Also the new Firefox is built against the nss from rhel7.4. Unfortunately it's too late to add the direct dependency to the 7.4 Firefox. 

Anyway, a simple fix is just to run "yum update" and update all packages.

Comment 17 Martin Stransky 2017-08-31 10:01:58 UTC
The doc is fine, thanks.

Comment 18 Martin Stransky 2019-08-23 05:59:09 UTC
Should be fixed now.


Note You need to log in before you can comment on or make changes to this bug.