Bug 145598 - segfault on compiling read-protected file
Summary: segfault on compiling read-protected file
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-20 01:02 UTC by John Smith
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 3.4.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 08:11:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Smith 2005-01-20 01:02:41 UTC
Ridiculous bug: gcc segfaults when trying to compile a file without
read-permissions.

Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3

How reproducible:
Always

Steps to Reproduce:
1. touch a.c
2. chmod a-r a.c
3. gcc a.c
    

Actual Results:

cc1: a.c: Permission denied
cc1: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.


Expected Results:

Only "cc1: a.c: Permission denied".

Comment 1 Jakub Jelinek 2005-01-20 08:11:54 UTC
Can't reproduce this with gcc 3.4.3-15.  Guess this was fixed by the non-existent
file ICE fix in 3.4.3-1.


Note You need to log in before you can comment on or make changes to this bug.