Bug 145600 - latex2html cannot handle -white option
latex2html cannot handle -white option
Status: CLOSED DUPLICATE of bug 127010
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 20:09 EST by Tomoyuki Kano
Modified: 2013-07-02 19:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomoyuki Kano 2005-01-19 20:09:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.5)
Gecko/20041108 Firefox/1.0

Description of problem:
When I use '-white' option to the 'latex2html' command, I do not get
the proper output as expected. 

Version-Release number of selected component (if applicable):
tetex-latex-2.0.2-21.2

How reproducible:
Always

Steps to Reproduce:
1. edit math.tex
--------------------------------
\documentclass{article}
\begin{document}
\[ \int_{-\infty}^\infty e^{-\alpha x^2} dx = \sqrt{\frac{\pi}{\alpha}} \]
\end{document}
----------------
2. run latex2html
 latex2html -white -notransparent -debug math.tex
3. view a generated image at math/img1.png




Actual Results:  gray background


Expected Results:  white background


Additional info:

Here is a bug in pstoimg program.
I fixed.

--- latex2html-2002-2-1/pstoimg.pin     2001-10-26 14:15:01.000000000
+0900
+++ /usr/bin/pstoimg    2005-01-20 09:16:07.744498381 +0900
@@ -1123,7 +1021,7 @@
       }
     my $had_nonwhite;
     if($opt{white}) {
-      $had_nonwhite = ($ps =~ s/(\n\d+ \d+ bop gsave) \d*\.\d+
(TeXcolorgray clippath fill grestore)/$1 1 $2/s);
+      $had_nonwhite = ($ps =~ s/(\s\d+ \d+ bop gsave) \d*\.\d+
(TeXcolorgray clippath fill grestore)/$1 1 $2/s);
       }
     $ps_changed = $had_papersize || $had_nonwhite;
     if($ps_changed) {
Comment 1 Jindrich Novy 2005-01-20 06:42:23 EST

*** This bug has been marked as a duplicate of 127010 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.