Bug 1456035 - cgroup-related SELinux denials for ns-slapd during upgrade of FreeIPA server from Fedora 25 to Fedora 26
Summary: cgroup-related SELinux denials for ns-slapd during upgrade of FreeIPA server ...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: 1456038
TreeView+ depends on / blocked
 
Reported: 2017-05-26 19:22 UTC by Adam Williamson (Red Hat non-Fedora)
Modified: 2018-05-29 12:31 UTC (History)
2 users (show)

Fixed In Version:
Clone Of:
Environment:
Last Closed: 2018-05-29 12:31:58 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Adam Williamson (Red Hat non-Fedora) 2017-05-26 19:22:13 UTC
I'm currently testing upgrades of Fedora 25 FreeIPA servers to Fedora 26, and noticing several problems, including several different groups of AVCs from SELinux. One is a set of several denials related to ns-slapd and cgroups:

[adamw@adam tmp]$ ausearch -if var/log/audit/audit.log -m avc | grep -i cgroup
type=AVC msg=audit(1495823938.927:115): avc:  denied  { search } for  pid=15384 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=1
type=AVC msg=audit(1495823938.928:116): avc:  denied  { read } for  pid=15384 comm="ns-slapd" name="memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495823938.928:117): avc:  denied  { open } for  pid=15384 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495823938.928:118): avc:  denied  { getattr } for  pid=15384 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495823964.398:129): avc:  denied  { search } for  pid=15886 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=1
type=AVC msg=audit(1495823964.399:130): avc:  denied  { read } for  pid=15886 comm="ns-slapd" name="memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495823964.399:131): avc:  denied  { open } for  pid=15886 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495823964.399:132): avc:  denied  { getattr } for  pid=15886 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824128.753:153): avc:  denied  { search } for  pid=16739 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=1
type=AVC msg=audit(1495824128.753:154): avc:  denied  { read } for  pid=16739 comm="ns-slapd" name="memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824128.753:155): avc:  denied  { open } for  pid=16739 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824128.753:156): avc:  denied  { getattr } for  pid=16739 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824243.202:179): avc:  denied  { search } for  pid=1206 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=1
type=AVC msg=audit(1495824243.202:180): avc:  denied  { read } for  pid=1206 comm="ns-slapd" name="memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824243.202:181): avc:  denied  { open } for  pid=1206 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824243.202:182): avc:  denied  { getattr } for  pid=1206 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824896.890:251): avc:  denied  { search } for  pid=1949 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=1
type=AVC msg=audit(1495824896.890:252): avc:  denied  { read } for  pid=1949 comm="ns-slapd" name="memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824896.890:253): avc:  denied  { open } for  pid=1949 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1
type=AVC msg=audit(1495824896.890:254): avc:  denied  { getattr } for  pid=1949 comm="ns-slapd" path="/sys/fs/cgroup/memory/memory.soft_limit_in_bytes" dev="cgroup" ino=11 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=file permissive=1

If you try with SELinux in enforcing mode (I took those AVCs from a run in permissive mode, to make sure we catch *all* the denials), you can see the errors caused by the denials:

May 25 15:31:53 ipa001.domain.local audit[15379]: AVC avc:  denied  { search } for  pid=15379 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=0
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.894470470 -0400] - ERR - _spal_get_uint64_t_file - Unable to open file "/sys/fs/cgroup/memory/memory.soft_limit_in_bytes". errno=13
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.895317836 -0400] - WARN - spal_meminfo_get - Unable to retrieve /sys/fs/cgroup/memory/memory.soft_limit_in_bytes. There may be no cgroup support on this platform
May 25 15:31:53 ipa001.domain.local audit[15379]: AVC avc:  denied  { search } for  pid=15379 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=0
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.896199804 -0400] - ERR - _spal_get_uint64_t_file - Unable to open file "/sys/fs/cgroup/memory/memory.limit_in_bytes". errno=13
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.896894586 -0400] - WARN - spal_meminfo_get - Unable to retrieve /sys/fs/cgroup/memory/memory.limit_in_bytes. There may be no cgroup support on this platform
May 25 15:31:53 ipa001.domain.local audit[15379]: AVC avc:  denied  { search } for  pid=15379 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=0
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.897496700 -0400] - ERR - _spal_get_uint64_t_file - Unable to open file "/sys/fs/cgroup/memory/memory.usage_in_bytes". errno=13
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.897911517 -0400] - WARN - spal_meminfo_get - Unable to retrieve /sys/fs/cgroup/memory/memory.limit_in_bytes. There may be no cgroup support on this platform
May 25 15:31:53 ipa001.domain.local audit[15379]: AVC avc:  denied  { search } for  pid=15379 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=0
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.950443644 -0400] - ERR - _spal_get_uint64_t_file - Unable to open file "/sys/fs/cgroup/memory/memory.soft_limit_in_bytes". errno=13
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.951039082 -0400] - WARN - spal_meminfo_get - Unable to retrieve /sys/fs/cgroup/memory/memory.soft_limit_in_bytes. There may be no cgroup support on this platform
May 25 15:31:53 ipa001.domain.local audit[15379]: AVC avc:  denied  { search } for  pid=15379 comm="ns-slapd" name="/" dev="cgroup" ino=1 scontext=system_u:system_r:dirsrv_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=dir permissive=0
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.951714405 -0400] - ERR - _spal_get_uint64_t_file - Unable to open file "/sys/fs/cgroup/memory/memory.limit_in_bytes". errno=13
May 25 15:31:53 ipa001.domain.local ns-slapd[15379]: [25/May/2017:18:31:53.952178920 -0400] - WARN - spal_meminfo_get - Unable to retrieve /sys/fs/cgroup/memory/memory.limit_in_bytes. There may be no cgroup support on this platform

...and so on.

There are so many different problems and errors with the upgrade process that I'm not sure which ones are critical, so I'm just listing them all as 'high' severity for now.

Comment 1 Fedora End Of Life 2018-05-03 08:13:00 UTC
This message is a reminder that Fedora 26 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 26. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '26'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 26 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 2 Fedora End Of Life 2018-05-29 12:31:58 UTC
Fedora 26 changed to end-of-life (EOL) status on 2018-05-29. Fedora 26
is no longer maintained, which means that it will not receive any
further security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.