Bug 1456053 - [abrt] dnfdragora-gui: _handle_dbus_error(): __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying (4)
Summary: [abrt] dnfdragora-gui: _handle_dbus_error(): __init__.py:250:_handle_dbus_err...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d75e8b27057385423bd00ae112d...
: 1534586 1541672 1543626 1567497 1572936 1573052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-26 21:51 UTC by Joseph D. Wagner
Modified: 2018-06-21 14:31 UTC (History)
12 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:26:50 UTC


Attachments (Terms of Use)
File: backtrace (1.81 KB, text/plain)
2017-05-26 21:51 UTC, Joseph D. Wagner
no flags Details
File: cgroup (289 bytes, text/plain)
2017-05-26 21:51 UTC, Joseph D. Wagner
no flags Details
File: cpuinfo (1012 bytes, text/plain)
2017-05-26 21:51 UTC, Joseph D. Wagner
no flags Details
File: environ (1.34 KB, text/plain)
2017-05-26 21:51 UTC, Joseph D. Wagner
no flags Details
File: mountinfo (3.04 KB, text/plain)
2017-05-26 21:51 UTC, Joseph D. Wagner
no flags Details
File: namespaces (102 bytes, text/plain)
2017-05-26 21:51 UTC, Joseph D. Wagner
no flags Details
File: open_fds (921 bytes, text/plain)
2017-05-26 21:51 UTC, Joseph D. Wagner
no flags Details

Description Joseph D. Wagner 2017-05-26 21:51:33 UTC
Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc27

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.12.0-0.rc1.git4.1.fc27.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying (4)

Traceback (most recent call last):
  File "/usr/bin/dnfdragora-updater", line 25, in <module>
    dnfdragora.updater.Updater().main()
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 156, in main
    self.__tray.run(self.__main_loop())
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 151, in __main_loop
    self.__get_updates()
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 117, in __get_updates
    return self.__get_updates_func(False)
  File "/usr/lib/python3.6/site-packages/dnfdragora/updater.py", line 126, in __get_updates_func
    pkgs = self.__backend.GetPackages('updates')
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 396, in GetPackages
    'GetPackages', '(sas)', pkg_filter, fields)
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 293, in _run_dbus_async
    result = self._get_result(data)
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 277, in _get_result
    self._handle_dbus_error(user_data['error'])
  File "/usr/lib/python3.6/site-packages/dnfdaemon/client/__init__.py", line 250, in _handle_dbus_error
    raise DaemonError(str(err))
dnfdaemon.client.DaemonError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying (4)

Local variables in innermost frame:
msg: ''
exc: ''
err: GLib.Error('GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying', 'g-dbus-error-quark', 4)
self: <dnfdaemon.client.Client object at 0x7fad4b13b160>

Potential duplicate: bug 1444825

Comment 1 Joseph D. Wagner 2017-05-26 21:51:39 UTC
Created attachment 1282769 [details]
File: backtrace

Comment 2 Joseph D. Wagner 2017-05-26 21:51:40 UTC
Created attachment 1282770 [details]
File: cgroup

Comment 3 Joseph D. Wagner 2017-05-26 21:51:41 UTC
Created attachment 1282771 [details]
File: cpuinfo

Comment 4 Joseph D. Wagner 2017-05-26 21:51:42 UTC
Created attachment 1282772 [details]
File: environ

Comment 5 Joseph D. Wagner 2017-05-26 21:51:43 UTC
Created attachment 1282773 [details]
File: mountinfo

Comment 6 Joseph D. Wagner 2017-05-26 21:51:44 UTC
Created attachment 1282774 [details]
File: namespaces

Comment 7 Joseph D. Wagner 2017-05-26 21:51:45 UTC
Created attachment 1282775 [details]
File: open_fds

Comment 8 Jan Kurik 2017-08-15 06:16:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 9 Fedora Update System 2017-12-29 23:20:36 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 10 Fedora Update System 2017-12-29 23:26:24 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 11 Fedora Update System 2017-12-30 19:53:19 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 12 Fedora Update System 2017-12-30 20:39:06 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 13 Fedora Update System 2017-12-31 21:26:50 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2018-01-01 22:10:31 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Michael Wray 2018-01-15 14:11:32 UTC
*** Bug 1534586 has been marked as a duplicate of this bug. ***

Comment 16 pixxxx 2018-02-04 00:03:05 UTC
*** Bug 1541672 has been marked as a duplicate of this bug. ***

Comment 17 RoPet 2018-02-08 20:33:13 UTC
*** Bug 1543626 has been marked as a duplicate of this bug. ***

Comment 18 David 2018-02-19 14:41:46 UTC
Similar problem has been detected:

I did a successful update, rebooted and then checked to make sure there were no further updates available. There were none so I quit the application and got an error message to say it had crashed.

reporter:       libreport-2.9.3
cmdline:        python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.15.3-300.fc27.x86_64
package:        dnfdragora-updater-1.0.1-9.git20180108.b0e8a66.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying (4)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 19 Ismaeil Beshkar 2018-04-14 10:43:53 UTC
*** Bug 1567497 has been marked as a duplicate of this bug. ***

Comment 20 zethan191 2018-04-29 04:09:05 UTC
*** Bug 1572936 has been marked as a duplicate of this bug. ***

Comment 21 JW Hall 2018-04-30 04:32:12 UTC
*** Bug 1573052 has been marked as a duplicate of this bug. ***

Comment 22 Victor Stratan 2018-06-21 13:39:17 UTC
Similar problem has been detected:

not sure what happened.

reporter:       libreport-2.9.3
cmdline:        python3 /usr/bin/dnfdragora-updater
crash_function: _handle_dbus_error
exception_type: dnfdaemon.client.DaemonError
executable:     /usr/bin/dnfdragora-updater
kernel:         4.16.14-200.fc27.x86_64
package:        dnfdragora-updater-1.0.1-9.git20180108.b0e8a66.fc27
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying (4)
runlevel:       N 5
type:           Python3
uid:            1000


Note You need to log in before you can comment on or make changes to this bug.